4th Glowforge: List of issues

Ok, I received my 4th :glowforge: and have had some struggles already. For the support people, scroll down to the bottom to Issue #4 for the actual issue I’m submitting. The rest is commentary and documentation on the differences between all 4 units I’ve had. So, Yay! I got a new unit that is all shiny and clean. And Boo! I’ve had issues…

Issue #1: Setup
So, this is my 4th Glowforge unit, so I’ve been to this rodeo before. And before anyone starts getting all passive aggressive with their snarky comments to restart this and restart that, note that I am the Chief Information Officer for a large financial institution and have 20 years experience in the field of Technology with multiple advanced networking and technical certifications. Laser design and cutting is mostly a hobby for me, but this unit is one of 60+ devices I have connected to my home network. I try and convince myself that I know how things work. Just kidding on the passive aggressive comment, I do truly appreciate this forum, and how everyone is prepared to help. Each time I have had an issue with one of my units, being able to use this forum, the resources and experience of the users has been exceptional. I am very thankful for the active users on this site and their feedback.

That being said, it took me almost an hour to get this latest unit operational from when I first turned the unit on. I went through setup at least 10 times, and got different errors along the way. I didn’t have any issues with any of my previous units. Once I was able to get though setup, I had a unit that that appeared in my list of 4 glowforges, but was listed as Offline. Since it took the name I gave it, the setup actually completed, is my assumption. Maybe the name I use has bad Juju, and need to pick something else. :blush:


The unit would not calibrate, and the image that showed was the bed without the crumb tray from when it was last powered on in the factory. So, I proceeded to reset the unit and start over, multiple times. The main error I would received during setup was Device error, while trying to setup your glowforge, it became no longer reachable or responded in an unexpected way.

I tried the setup from multiple devices on multiple wireless SSID’s. The Nighthawk X10 wireless router is literally 5 feet from the :glowforge:. Everything was reset or restarted multiple times. I searched the forums and found that there many other users who experienced difficulties with setup. I, unfortunately, cannot tell you what I did to make it finally finish the setup, but at one point the machine finally went into calibration.

Issue #2: Offline
Like I said earlier, I got the setup completed, and the unit would appear in the offline status. Once I got that sorted out by luck alone and it finished the initial calibration, I would try to load a design to cut, and it would go offline. I would also get an error to pop on the screen and the site would go back to the home page.

This happened a number of times, but was eventually able to actually cut something. So, I hoped everything was golden.

Issue #3: Camera is off
This :glowforge: has a significantly different view from the camera than my last 3 models. Good thing is that it shows the bottom of my crumb tray. Bad thing is that more of the top of the print area is out of view. Not a huge deal, but definitely inconsistencies in the configuration of the different units. This one shows more of the right side as well, but any loaded design in the UI is about 1/4" off from what actually gets cut. My last 3 units were much closer. I’ve seen complaints in the forum on this, but with a wide angle lens, I can live with this abnormality. There definitely needs better QC from the production of these on the wide angle camera config.

Issue #4: Gift of Good Measure Not Working
Since my last unit had issues cutting in the lower right-hand side and hitting the sides and bumping the print out of wack, I was going to try and cut a Gift of Good Measure keychain to test this unit. when loading the design, sometimes it says no artwork. I try to reset the design and get the same error and returns me to the home page. I cannot click on the GOGM-testing-5 button without getting the error. I was able to bring up the founders ruler and metric GOGM and print them without issue.

Support: Can you reset the imperial Gift Of Good Measure for me?

Let me first say that :glowforge: support has been great at getting me replacement units. They have arrived fast, but sometimes after some delays in the communication process. I am technically disabled, as I have MS. No, I’m not looking for sympathy, but understand that since I cannot lift this at all by myself, each time I get a replacement, I need to arrange for a co-worker to come to my house to make the swap. That includes boxing up the old one and getting the shipment ready for return. I print thank you stuff for his charity, so he’s happy to help. That is a monumental challenge for someone like me each time I’ve had to get a replacement. I hope that this was the last time.

The good news is that this one cuts through proofgrade draftboard at the default settings. It also cuts all the way to the bottom right-hand corner without bumping into things. I really think for the Pro units, they should have an Ethernet port in addition to wireless. It also should not be this difficult to get a unit setup once out of the box, but this appears to be on a case by case problem. My other 3 were a breeze to setup. So outside of the setup shenanigans, and inability to reset designs in the UI, I’m hopeful that this unit will be my last.

Thanks again to everyone on this forum who helps in the Problems and Support threads, and for :glowforge: support for arranging my replacement units. And for the unit on its way back for repair, sorry it’s so dusty!


Did you reboot your router?


1 Like

Ah, that must be it. Let me try that next time. :face_with_raised_eyebrow:


I really hope this unit works flawlessly from now on and that you will share your creations with the forum.

1 Like

Well no wonder why, you’re at v0.4 - you need to at least be at version 1.0 :smirk:.

Well your journey has sucked, but you make amazing and awesome stuff.

1 Like

Thanks for letting us know. I’ve added the “(Medium Draftboard) Gift of Good Measure Keychain” design back to your account. It will appear on your Dashboard at https://app.glowforge.com.

Please let us know if there’s anything else we can help with.

1 Like

Glad to know you’re back online; here’s hoping the 4th time is the charm! Your work is beautiful; I’ve admired much of it on Pinterest before seeing you here. :slight_smile:

Also you win brownie points with me for using Smugmug, since my son was on their UI design team for several years (until he and the founder decided to go off and start Cake).

1 Like

The design for the GOGM loads now, but I still get the error if I click the … button.

I’ve been a smugmug customer for a long time, and just don’t have the energy to find something else. It works for me and displaying my pics!

One year for my birthday he gave me my own secret feature. That was one of the cooler gifts I’ve ever gotten!

They’re an awesome company, treated him really well. They have a professional face painter come in for employee photos, to make them into superheroes, among (multitudinous) other cool things. He hated leaving, but really wanted the chance to work on Cake.

This was his employee photo (he said all the good superheroes were taken so he chose a villain instead):


Cool. They have been doing the staff face painting thing for a while, and is great for PR and the employees. Fun!


My third one will be here this week. I hope it goes as smoothly as the first two.


Thanks for letting us know about the error you’re running into when you click the “…” button. We’re seeing this, too, and we’re looking into it now.

I’ll update this thread as soon as I have more details, and I apologize the inconvenience in the meantime.

I have more details much sooner than I expected to when I posted that six minutes ago!

This should now be resolved. Could you please try again, and let me know if you’re still seeing this happen?


Sure, I’ll try this tonight when I get home. Thanks!

Oof. I just wanted to jump in and apologize for the poor fortune in getting you such troublesome units, and thank you for your amazing patience. Now that you’ve got a unit humming, I can’t wait to see what you’ll make. And please know that our team’s looking at the rest of the problems you reported as well. Even though you worked through them, you shouldn’t have had them in the first place.


Thanks Dan. I am hopeful that this one is going to be amazing. I’m a little worried what will happen when the warranty runs out, but we’ll see how this one performs. :smile:

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.