500 errors on Catalog


#1

Hey Glowforge team,
I’ve had my printer a few weeks, but I am hitting 500 errors occasionally, across the whole site. Most recently I’m getting a 500 error on the catalog page. I’ve tried multiple browsers, devices and wireless connections. Is the catalog down?
I go to app.glowforge.com, sign in and hit the catalog tab. 500 “Something went wrong” starting last night and all day today.

Please help! I want to print some catalog pieces with my new materials.


#2

One thing you might try is to change your DNS (Designated Name Server) settings, just to see if the problem is on your end. I had a similar issue with a particular website and was able to get it to work by switching from my ISP provided DNS to the Google ones. I don’t know what OS you’re running or I’d describe how to do it, but it isn’t at all complicated or difficult. If you’re still having difficulty it might be worth a shot.


#3

I’m sorry you are having issues browsing our catalog! We’re looking into this now - I just have a few questions that will help us as we investigate.

  • Are the 500 errors still showing up for you today?
  • If so, have they also been affecting the Glowforge app as well?
  • When was the last time you tried (if you recall what time it was, please let me know)?

Thanks for letting us know.


#4

I’m still seeing the 500 error today. I just checked on my phone 9:55pm PST.

I’ve had it affect the store in the past, but never the app. Currently the only page showing the 500 error is the catalog. I can access every other tab successfully.
Thanks for looking into it!


#5

I’ve tried it at work, at home and over my cellular data, so it’s unlikely a DNS issue.


#6

I’ve had the same issue for several days now. Actually don’t think it’s worked since I received my glowforge. I could access it before I got it, but not now.


#7

Day 4, still showing a 500 error. I’ve once again tried multiple browsers, cleared cache and multiple wireless points. Really wanted to print some catalog items over the weekend. :frowning:


#8

Why is it taking so long to fixed this 500 error !!! can anyone from glowforge let us know… Its been days so far and all we get is the same message “we are looking into it” If you want details I’m trying it on my samsung phone “chrome”, Linux machine at work, “chrome and firefox”, at home running desktop computer, windows 10 with the same browsers. We get the same 500 error… Any news please…


#9

Maybe it’s your specific account. Access has to be granted. Not having an issue on my end.


#10

Perhaps but Its weird that I was able to see the Catalog without the error last week and this week I have no access to it… I mean I don’t think this is an isolated thing since there are others having issues with it…


#11

I happen to be a web developer, so I’m reasonably confident it’s not an issue on my side. A 500 error can be one of about 15 different server side issues. GF has simple error reporting turned on so we can’t really troubleshoot further and we certainly can’t fix the issue. All we can do is wait; something I’m well versed in by now. :slight_smile:

@vee any updates?
With a fresh browser cache I just tried to access at 11:57 AM PST from two different browsers (Edge/Chrome) on a Windows 10 PC.
I’ve tried both a direct link to catalog.glowforge.com and by clicking the “catalog” tab from the app.glowforge.com page. Both produce the generic 500 error.
Happy to have a call or come by the GF office if that would help. :stuck_out_tongue:


#12

Thank you so much for your patience. Would you please let us know if you’re still experiencing trouble when visiting catalog.glowforge.com?


#13

Amazing Rita… Thanks Its seems to work… Running it at my desktop Window 10 computer (Chrome)…

I’ll go and get my order


#14

Also working here! Thanks so much!
Augmented robot arms for everyone!
trex_skype


#15

I have the 500 error when trying to order supplies for weeks with no response to emails. Have tried all the suggestions and still problem persists, It is useless to have the laser when you can not order supplies or get any help from Glow


#16

Please start a new thread in the Problems and Support category so that the Support team will see it. They do not check for posts in old topics, but they do see New threads. A 500 error has to be fixed by them in house, so the sooner you create a new thread, the sooner they will see it.

Good luck!


#17

Have you tried deleting anything in your cart and updated your CC info? I had the 500 error a few weeks ago but I placed a new order Saturday without issue and just got an email that it was shipped yesterday.


#18

Can not delete because when I select the cart I get the error

You have been honored by receiving this message from my iPhone sent to you a few minutes in the past when I wore a younger man’s clothes


#19

Super frustrating that you’re not getting some response from Support.

They probably won’t see it here so likely need to send Support an email. :frowning: