AD Vector Engrave Issues

I’m having an issue with Affinity Designer (AD)…I’m trying to engrave a cutting board with an vector that was made from mostly fonts. My workflow:

Use artistic text tool to add fonts
Convert to curves
Boolean Add
Boolean Divide
Boolean Combine

Now I’m left with a single set of curves that appear to be closed.

Export as SVG, upload to GF and the ‘empty’ parts of the letters are filled…

This doesn’t happen with all fonts, which makes me think it is an issue with the shape not being closed. I can’t for the life of me figure out how to fix it. I would love any help to get this fixed…thank you!

Have you tried doing the engrave? I’ve had stuff display weird but print fine.

Also, open it in Inkscape and see what it looks like. Often looking at it in another program will reveal the problem.

Probably a Fill Rule issue…I believe AD users are afflicted with it as well as CorelDraw users.

Instructions for fixing it in your file are here:

You can read a discussion of the issue higher up in the thread.


I really, really wish Glowforge would fix this bug.


Rasterizing it would also likely solve your issue.


I need to start rasterizing. I have always done vector engraves because it’s easier to set up, at least if you don’t have issues like this. I would have to re-develop settings for rasterized art, so I keep putting it off…


Would you be willing to upload this SVG @joshua.ballard ?

I think that the linked thread contains the information needed to solve your issue, but I am curious what would happen if I opened/resaved the file in Illustrator. I doubt it would fix the problem but it is easy to try…

If you rasterize it as black the settings should be pretty much identical to the corresponding vector.


Do you raserize to a particular DPI? It seems I often end up with ‘fuzzy’ edges when I try to engrave raster versions of the fonts. The vectors are nice and clean and crisp.

That did it…flipping the nodes worked.

Minimum 300 PPI. If it isn’t something big, I will do 600 PPI. Just have to be careful of file sizes. Haven’t pushed the limits in a little bit, but I seem to remember around 25mb being the limits.

You might be able to get around this by linking the rasters instead of embedding, as I think it will ask you to upload each linked raster one by one.

1 Like

This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.