Add Artwork Button Broke

I can load an image from my previous uploads. But when I go and try to upload new artwork, the button just doesn’t work. I can press it and never get the window to choose the file to show up. It was working yesterday then just stopped. I have tried refreshing the page and even logging out then signing back in. It just doesn’t want me to upload more than one image.

Thanks for letting us know about this, and I’m sorry for the trouble. We need a bit more information to investigate. Please do the following:

  1. Go to
  2. Click the link underneath “Share my system info with tech support”
  3. Copy the highlighted link
  4. Reply to this, and paste in the link provided

This will help us understand the circumstances around your error so we can work on it for you.

I talked to the support help box thingy. They helped me. I was using explorer and chrome made the button work. issue solved thanx everybody =)


I’m glad to hear that! If you run into any other trouble, please don’t hesitate to reach out. We’re here to help!