"Add Artwork" stopped working


#1

After the latest software changes* I can no longer delete all the artwork in the app and “Add Artwork” back.

When starting from the home screen, and choosing “upload”, the file loads correctly. Here’s a screenshot:

If one then presses Ctrl-A, then Delete, the workspace is cleared.

Then, if I click the “Add Artwork” button, and add the file back, it doesn’t come in properly. It’s completely filled with black. This is exactly the same file that was loaded moments earlier. I have confirmed the issue with 3 separate files.

Here’s a screenshot:

Basically, I need to go back to the home screen, delete the project, and upload again, instead of re-loading in the same workspace.

*The changes I’m talking about are the ones described here:


No artwork, but that turns out not to be the issue
#3

Same here! When I delete everything in the GFUI and load a new svg, (wirhout going to the Homescreen), then it loads totaly black and the „no artwort“ error comes up …
That has nothing todo with the autosave in my Opinion


#4

I have the same issue but to get around it for now I just hit F5 (Windows OS) to refresh the screen and the preview changes from solid black to the real image/SVG that was loaded.


#5

Thanks for the hint, have to try it!


#6

Thanks f_debastiani and ruthsolomon for confirming the new bug is present for you as well. Yes, it does seem that just refreshing the browser page does work.

I still wanted to report the new bug/behavior change.


#7

yep same here every single time, and yea a refresh works but sometimes its like it has to reload the entire design for me. Hoping this gets corrected soon.


#8

Another confirmation… I use this feature extensively when I’m cutting multiple variations during prototyping or when swapping materials.


#9

I’m glad you were able to work around the problem.

We’re seeing this too, the team is looking into it and I’ll update the thread when I have more information.


#10

Wow…just came to this – had a couple of days of downtime and suddenly ran into this exact same thing tonight. Glad the bug is being worked on…


#11

Same here. I have had to refresh my window up to 4 times for one project, and it’s been slow, and glitching ever since the update. I also can no longer add from the camera interface screen, and if I do I have to refresh the screen for it to upload onto the viewing area.


#12

Thank you for your patience. We’ve made a change that should resolve the issue you reported when working with your designs in the Glowforge app. Could you please try again and let me know if you’re still experiencing any trouble?


#13

It does seem to have been resolved. Worked fine for me just now.


#14

I’m glad! I’m going to close this thread - if the problem reoccurs, go ahead and post a new topic. Thanks for letting us know about this!


#15