Also stuck in calibration


#1

Same shit as everyone else. Endless calibration. I’ve tried all tips and poiters given here in the forum.
I turned off my GF
Logged out of the app
Restarted my PC
Positioned the head directly under the camera
Restarted the app

Nothing… “Calibrating the head of your Glowforge. This can take a few minutes”.

I have treid these steps about 5 times now. Still nothing.
Anyone?


#2

Did you turn off the overhead lights and make sure the sun isn’t shining on the GF?


#3

Yup. No sun, no lights…


#4

What exactly is it doing?

First thing required is a decently strong connection to your WiFi router. How is that connection? Do you know how to log into your router to see the currently connected devices - that usually gives a signal strength for the device as well.

Assuming you have a connection to the router:

Is it doing nothing at all - just sitting there?

Is the head hunting around?

Is the white light flashing at all at any point?

Have you cleaned the lid camera? If the lid camera lens is having trouble seeing (for example, if it’s dirty), it won’t be able to recognize the head or the logo on the head.

Have you cleaned the top of the laser where the logo is?


#5

Wi-Fi is no problem. Strong and steady connection.
Could be that the lens is dirty. Will give it a try.
I got it to work eventually, so now it’s cutting again, but before it just kept calibrating. The head would go to one spot, stay there for a while, then move again. Every time it moves, the white light is on. When it stops, the light switches off. After about 10-15 minutes of this, the head would stop moving but it would still say Calibrating…
But yeah, will give it a good cleaning, see if thet makes a difference. Thanks!


#6

With so many reports of the same thing, and everybody confirming that their WiFi is working great, when will Glowforge admit there’s a problem with either their firmware, or the WNIC in the units?!


#7

The white light means that it is receiving instructions from the cloud, which is good, because it indicates you have a connection to your network, the internet, and the Glowforge servers.

The hunting around is generally because it can’t locate the head and/or logo on the head properly. Try making sure that both the lens is clean and the top of the head where the logo is, is also clean. Sometimes it can also get confused if you have material in the bed that has holes in it (that it can confuse with actually being the head) but I think it’s more often a case of the optics being dirty.


#8

His last post says that the head is hunting around, which indicates a WiFi connection is present - so it’s not a WNIC issue.


#9

We can’t say that. Just because it connects doesn’t mean it’s working properly. Heck, I had a problem with the NIC in this computer I’m using right now. It was connected to the network (as shown by both sides) yet it couldn’t access any network resources.

My Glowforge was connected last week yet I had “the calibration issue” for several hours, like others. Sometimes it would show offline (even though the router would show it connected). Even though it began working hours later, I’m not at all convinced there isn’t an issue with the NIC in general. But I’m sure as hell hoping it’s just a firmware issue.


#10

I had the same issue that is being described, tried rebooting the router, etc. verified the connection was active via “connected devices” in the router. Manually moved the head (power off), and had no luck.

What solved the problem for me was using a Zeiss wipe on the lens, and then everything seemed to work properly.

I’m guessing that for some reason, the camera wasn’t reading the logo on the print head, and therefore could not complete calibration.

As a side note, the forge had been offline for more than 7 days as I had been travelling.

Hope that helps others with the problem, and support with tracking down the issue.

I’d echo what others have suggested: having more detailed messages than just “calibrating” would be helpful.

Todd


#11

Also good to wipe down the top of the head after you’ve cleaned the camera lens - it can get dusty & dirty too. I’ve also found that if I have something on the bed with a GF logo (like the ruler) can confuse it.


#12

At the very least updating the troubleshooting section with the info that is being thrown around in this [awesome, thanks to all of you] thread seems like a good idea. (He says, not having looked at the troubleshooting section of the manual. If it’s already updated, just ignore me :wink: )


#13

Funny, also, I was reading this article about network diagnostics this AM and wondered how wireshark might be used to troubleshoot issues along these lines…

https://jvns.ca/blog/2018/06/19/what-i-use-wireshark-for/

I’m not nearly deep enough on TCP to dig into this, maybe someone else is?


#14

They could add some wifi connection information to the app. If we need to be wary of weak signals, why isn’t there a signal strength meter we can see, so we know with no ambiguity how the Glowforge sees the network? The wifi hardware in the machine undoubtedly has a number tucked away that represents signal strength, and it should be trivial to get it to the browser app in some way.

If calibration problems can be caused by the camera not seeing the logo, why isn’t there a warning for that too? Clearly, the machine knows what the issue is. After failing to find the logo for a couple of minutes, the app could just tell us to check the lens and center the logo.


#15

Well, that’s the thing. You can easily just install WiFi Analyzer on your phone and know the strength of your signal right at your 'forge. My thinking is the WNIC and/or the antenna is just shoddy and doesn’t pick up as well as… any other WiFi-enabled device on the planet.


#16

A wifi analyzer on my phone only tells me the signal strength seen by my phone. It’s better than nothing but it is not definitive.

You even said you suspect the antenna in the Glowforge may be shoddy, in which case an external analyzer is even less useful.

“Signal strength” can also include stats like lost packets, which an external analyzer can’t help with at all.

To troubleshoot signal problems, we should know the signal quality seen by the machine. I feel like this should not be a controversial idea.


#17

The only good thing about seeing others having the same kinds of problems I’m having, is that at least I know I’m in the same boat as other people! A troubleshooting section for this would definitely be helpful though as it would be great to narrow down where in the process things are going wrong. For example, my GF isn’t even trying to move the head and is stuck on calibration even though I can see it on my network and in the app. It wold be great to go through some well documented tips that at least narrow down whether this is hardware or network related!

Guess I’ll just be waiting for customer support to get back to me at this point though :sweat_smile:

Edit: Also, I haven’t seen anyone else posting anything about error codes coming up, but I had finished a print, went to start the next one and got an error message about path movement. Does that ring a bell as something similar anyone else has seen prior to endless calibration?


#18

I think you’ve missed my point. You’ll be able to tell if the signal is reaching your phone and at what volume. If we presume the antenna or NIC in the Glowforge sucks, and you see that your signal on your phone is on the low side (-70dBm, -80dBm), you could expect your Glowforge will not function. However if you’re seeing a -40dBm, -50dBm, there’s no reason I can think of why your Glowforge wouldn’t work.


#19

I understand your point. Seeing what the Glowforge sees is still a better user experience and it also prevents Support from taking the time to recommend wifi analyzer apps. Or, worse, telling us that we are on our own.


#20

That sounds like you hit print before it finished the lens calibration procedure after the prior print.