Also Stuck on Calibration


#1

Yep, another one of these.

I was able to print something out successfully earlier today, then (leaving the glowforge on) took about 20 minutes to modify the file so I could print out another one. Then I switched out the piece of pg draftboard I had and noticed that the app UI wasn’t updating to the new piece of draftboard. Refreshing the app didn’t work, so I went and restarted my Glowforge.

Of course now it’s stuck in calibration. It does the first part which moves the print head under the camera, and then moves it to the leftmost side, but the tube stays right there and doesn’t move up or down. I’ve done all the things I found in the forums (move the print head, cover up the top, reduce load on wifi) and none of that worked. Kept restarting and trying for maybe 2 hours and nothing has worked. I’ve left it on for like 20 minutes before restarting. Nothing. It’s sitting next to a giant window and I’m bundled up because I can’t get the vent out unless I open my door so it’s probably not a hear issue.

Any other ideas?


#2

Turn off the machine. Log out of the app. Sign back in to the app a minute later. Move head under lid camera. Turn on machine. And give it some time for that first calibration. (10 minutes.)

After that, if no go, turn it off and back on and try one more time with the calibration.


#3

It sounds to me like it’s actually not calibrating. If so, the app has nothing to do with that at all.
@wing, please confirm… When you say…

…are you saying the head ends up mid-left? Never goes to upper-left?

If so, app is out at this point. Logged in, out, multiple times, or anything else doesn’t play into it yet. The only thing required for calibration is an internet connection.

From what I see in your post, it seems you’ve performed the common things that could help your situation. Since the only needed element is internet, I do wonder if your wireless connection is weak for some reason. Not that anything’s changed for you, necessarily, but interference could be the cause. I’ve always used “WiFi Analyzer” on my phone to see what other WiFi broadcasts are around. It’s free. It’ll show you what else is around and what channels they’re on. That will allow you to tune your WiFi accordingly. Find a channel that’s not being used at all (if you can) and use that.

Another thing to try is move your WiFi closer to your 'forge or vice versa. (It’s a REAL pain to move your 'forge, but it might be worth it.)

Let us know! :slight_smile:


#4

I had weird behavior like this for the last two days at a Maker Faire where the WiFi network was saturated and getting rebooted. The GF always eventually recovered.

The GFUI also got pretty flaky on that network. It’s a bummer having a cut ready to go, then the page reloads losing everything. It would be nice to be able to explicitly save a setup to the list on the “home” page, under a new name, so that you’d know you had it available for later. I had “keychains” loaded, with the shapes I wasn’t using deleted, and an image loaded to engrave, and every time the GFUI reloaded, I had to redo that work. Not the end of the world, I guess, but inconvenient when cranking out keychains at a Maker Faire.


#5

@Tom_A That’s correct. It stays mid-left. Wireless is strong; WifiAnalyzer says everything’s green and I’m on the best channel. My GF is 12 feet away from the wifi access point and can’t move either the GF or the access point closer.


#6

Does anyone know what the default host name of a GF looks like? Is it something like “BRWEC55F9886A34”? I’m trying to check its connection via my router’s admin interface.


#7

Okay so I am playing with my router’s DHCP client list. I wasn’t sure which one in the list was the Glowforge so I just turned off my GF and… nothing changed in the DHCP client list. But the app can read the offline/online status of the GF so clearly it’s connected to the servers somehow…

I am very confused right now.


#8

The WiFi MAC address identifies as Texas Instruments Manufacturer


#9

Thanks!

Hmm I don’t have anything like that so it doesn’t seem like the GF is connected, but the app is reading its online status…


#10

It doesn’t report a hostname to my DHCP server, but it will have a MAC address beginning with 80:30:DC (assigned to Texas Instruments for the WL18MODGB wireless module inside).


#11

Damn…

These are correct.

Hmmmm… 12’ apart you say? Is that 12’ of concrete and steel by any chance? :wink:

Gosh, man… How 'bout you bounce your WiFi router? Could have nothing to do with the 'forge. Maybe you’ve got a bad ARP cache or routing table hanging you up.


#12

Thank you so much for the details. I’m looking into it now.


#13

I finally decided to restart the GF one last time before washing my hands and then walking in the kitchen to take out my pork roast. And as soon as I came back to my computer after setting the roast out to cool… I see Ready on my GF app. Maybe it’s because the sun went down further? Or a football game ended so my neighborhood stopped simultaneously streaming a thing? Or maybe it wanted dinner???

@semhar Thank you! I guess it just started working now so you don’t need to fix my GF specifically. But I hope that there are logs you can access remotely to help diagnose what was going on so you can learn something from this. Let me know if there’s any other information I can give to help y’all with this.

@scott.wiederhold Okay awesome! That’s one of the "unknown"s on my list. Weird thing is that it stayed there even with the GF off. Hm.

@Tom_A Mostly air and an IKEA couch, so basically air, two pieces of particleboard with a piece of fabric taped on it. :slight_smile:

Thanks y’all for the help! Gonna go print the thing before bedtime now.


#14

The listing in your router is a record of the DHCP lease. They remain active for a set period of time. When you turn off your Glowforge, the lease will remain listed until it expires (could be a day, could be a week, depending on the configuration).

When you turn on your Glowforge, the router will reassign the same address if it isn’t expired, and it will update the lease time.

Easiest way to tell if the device is active is to ping it from a command prompt. The Glowforge will respond to local pings if it is up and connected to your network.


#15

when you said

That was my first thought. Perhaps the sun flooded the camera.


#16

That makes sense. I thought it was in real time because when I turned off my phone’s wifi it disappeared fro the list.


#17

Yeah, except it’s not super sunny (I live in Seattle), I have black curtains, and I tried covering the top up with no success. Plus the GF calibrated and printed fine an hour before this happened…


#18

:joy::rofl:


#19

Yet another person experiencing what appear to be calibration issues. It took maybe 10 minutes on day 1 to calibrate the unit, something we figured we would only need to do during initial setup and possibly again after moving the unit. We printed a couple things successfully after that on Saturday. I didn’t get to use it on Sunday, and as I’m sitting down to work with the Glowforge Pro today, the status says “Needs Calibration” - and has done so for several minutes (I didn’t mark the start time because honestly I expected it to be very brief.

A couple things to note for support/software development:
That status message says “Needs calibration” (or specifically, it says “NEEDS CALIBR” because the way the page is designed). First, the design of that status popup should allow the user to read the message, and second - perhaps the wording should be different. “Needs calibration” suggests that there is a step that the user must take, yet there’s no information on how to manually initiate the process. If it’s an automated process that requires nothing from the user but patience then perhaps it should read “Calibration In Progress” or “Calibrating - Please Wait.” Some kind of progress indicator would also be very helpful and reassuring. The Epilog, Trotec, and ULS lasers I’ve used have no such similar startup process, so right now despite hundreds of hours of general laser experience under my belt, I’m not really sure if my Glowforge is working right or not.

Also, am I really going to have to spend 10+ minutes calibrating this thing every time I turn it on? I don’t like the idea of walking away or leaving the room while the machine is on, and 10+ minutes to calibrate means even a really quick job is likely going to mean a minimum 15 minute time commitment (and energy/labor costs, for those doing work for hire or commercial use).


#20

Other than a possible slow or weak wifi connection there should be no reason the calibration routine should take more than about 90 seconds once after it’s first turned on. I do not know if that time is lengthened with slow internet.

Very consistent 60-90 seconds for Calibration on my Pre-Release unit for many months now. I turn the GF and computer on in the morning. GF is always ready long before the computer.

BTW: The GF is on and unattended 90% of the time. Only when engraving or cutting would I ever bother to watch it. Have forgotten to turn it off for days at a time.