Also stuck on Device Error, Wifi won't connect! (resolved)


#1

Ugh. I read the other thread with no luck. My router’s firmware is up-to-date. I can’t get my GF to connect at all! I also got the “Device Error!” message when I get the Glowforge-XXX-XXX network to try connecting back to my home network. Tried on 2 laptops, tablet and a phone. Have reached out to support but don’t really want to wait 3 days for a response.

(Also, upon delivery the box was missing 2 of the plastic handles on the outer shipping box! Didn’t know to look for them until I opened it and followed the setup link to watch the video!)

Any help would be greatly appreciated! I downloaded the WiFi Analyzer mentioned in the other thread, the lock icon does appear next to my home network. I even free-typed in my network name and password with no luck on a few attempts (clicking my own network doesn’t prompt for password)


#2

I’d love to help. Can you tell me exactly what steps you’ve taken to get to this point?


#3

I had to connect with Chrome. Also, sometimes it helps to move the router as close as possible to the machine for the first connection.

The setup steps for connecting the WiFi are here:

https://glowforge.com/support/topic/unboxing-setting-up/unboxing-and-setting-up-your-glowforge#Sign-in-and-connect-your-Glowforge-to-Wi-Fi

And the WiFi troubleshooting is here:

https://glowforge.com/support/topic/troubleshooting/wi-fi


#4

Thanks! I’ve rebooted everything, still no luck. I’m within a few feet of the WiFi Extender I installed over a year ago, and I get good signal where the GF rests on both my main and my extended network.

I followed the setup prompts and got to the “Huzzah!” device found screen (except from my Windows 10 laptop which is the only device which wouldn’t get me to the Huzzah! message, but my older XP laptop did), then when I link back to my home network is when I get the “Device Error!” message.

It does tell me my network is unsecured, but it is secure and WiFi Analyzer shows the lock on it. I have both clicked on my network, as well as tried typing it in and copy-pasting my password.


#5

As for the Troubleshooting guide (Thanks for the link Jules!), This was the pertinent section for me:

Started Setup, Saw “Device Error” Notification

“The network requires a password” - I do not get this prompt at all. The only time I get this prompt is when I go to the +Join Other Network option. Again, I hand-typed my network on this option since clicking the supplied version of my network doesn’t prompt me for my password. When I select my own it says (unsecured network), but mine is password-protected.


#6

Sorry you are having troubles here. One thing I have noted is that most of the time someone comes up with a solution to these connection errors, but it takes some persistent trouble shooting protocols to figure out the just what that is.

What security protocol? Someone recently posted regarding issues with connecting and it was noted that he was still using WEP security. just trying to isolate things.

I have had the best success with using wireless mobile device to connect to the Glowforge ad hoc network while the teal button glows. That seems to be the best way to get the Glowforge connected to whatever wifi I need it to connect to.

Then I have a desktop computer running Chrome to run the app and manage the Glowforge.


#7

Just a note: he was using the ancient WEP security. WPA isn’t as bad, but it’s still considered bad. For anything in the last five years, people should be using WPA2.

Edit: Whoops… I meant WPA not WAP… doh! fat fingers…


#8

Originally I had it at WEP 128 bit, but then I changed to WPA2 (not WAP2, I don’t see that as an option), but that’s been giving me more problems.

I had minimum success turning off both as “disabled”, got it to connect briefly, then it never switched back in the browser. It appeared to do the calibration but nothing showed up on the app. The app afterwards on my account shows my model number but lists it as “Offline”.

All of this could have been avoiding with a built-in Ethernet port, and I’m still banging my head on the wall over this. I have been messing with this for hours now and I am beyond frustrated.

I did install Chrome, and it will not give me the “Huzzah!” message, it keeps cycling waiting for me to connect to GF.

Should I just buy a new router?


#9

When I connect to Glowforge XXX-XXX, it’s status reads
"No Internet, Open"

I feel like my problem is that the software does not ask me to put in my password. When I go from GF back to my network, I don’t receive the password prompt that they mention in the troubleshooting guide.

When I do get ready to switch to the GF the text reads “connect your Mac to Glowforge”, but I’m on PC! Not sure if that has any bearing at all or if that’s just boilerplate text that everyone gets regardless.


#10

DOH! Typoed my response. I meant WPA2, not WAP2. Glad you spotted it.

You really don’t want to run your wifi as “open” (what I’m thinking you might have meant by ‘both as “disabled”’) without some sort of WPA/WPA2 protection.

If you meant “both” to indicate “both wireless frequencies” (2.4GHz and 5GHz), then you should know the Glowforge only uses 2.4GHz.

It’s important to keep in mind that after you make the wireless security setting change, all your wireless devices – including your PC/laptop, if it’s using wireless – will need to reconnect to the router with the new WPA2 settings. You should refresh your PC connection before you continue setting up the Glowforge, perhaps simplest by rebooting.

These are the settings that I use on my network, and recommended to other users which works.
image


#11

You really don’t want to run your wifi as “open” (what I’m thinking you might have meant by ‘both as “disabled”’) without some sort of WPA/WPA2 protection.

Totally agreed! I had them disabled just for troubleshooting. I never intended to leave them permanently off. I mainly need to get the GF to show me it’s working without any physical problems.

If you meant “both” to indicate “both wireless frequencies” (2.4GHz and 5GHz), then you should know the Glowforge only uses 2.4GHz.

Thanks. I saw this in the older thread so I haven’t been touching the 5GHz channel, only the 2.4GHz. I meant both WEP and WPA2.

It’s important to keep in mind that after you make the wireless security setting change, all your wireless devices – including your PC/laptop, if it’s using wireless – will need to reconnect to the router with the new WPA2 settings. You should refresh your PC connection before you continue setting up the Glowforge, perhaps simplest by rebooting.

Great point, but I already had the changes working before I changed to the GF XXX-XXX.

The best success I’ve had so far was with security disabled (NOT a long-term solution), got the “Huzzah!” Message, was prompted to switch to GF XXX-XXX, did so and finally got what appeared to be the calibration cycle, but the app still had the turning arrows telling me it would switch back to my network but stated I might need to do it myself. So, it appeared that the software froze up on me? But the lens/laser arm moved around as it said it would, but then the software did not let me proceed to the next step.

When you did your setup, did GF ask you to type in your network password? I feel like that’s the step I’m just not receiving from the software. I’ve tried Windows 10, Windows XP, Android phone & Android tablet, Microsoft edge, explorer, Chrome and Firefox.

I’m still very concerned that Glowforge still considers my network “unsecured” and never asks for my password. Everything else I’m running shows the Lock symbol on my network, I had to re-enter my password on my devices when I switched over to WPA2, but yet Glowforge still doesn’t give me any option to enter it.

Hmmmm. I’m wondering if I should type in my IP address for the "+Join Other Network option? Perhaps typing the name for it by hand is causing some kind of conflict?

Fingers crossed, here goes another mass reboot of everything.


#12

This could be related to a firmware update. Out of the box, one of the first thing the Glowforge will do when connected to the network will be to start downloading the freshest firmware, which I believe has improvements for Wireless connectivity and a myriad of other changes. (The contents of the firmware update is not an official factoid, though… I’m basing it on reading the last few months of forum updates from people…)

I can talk a good talk, but sadly, I don’t have my Glowforge yet. Perhaps an actual owner can weigh in. I will say that the general consensus in the forums has been that using Google Chrome helps get the best results as it appears to be the most error-free web experience with the GFUI.

As long as you’re sure your wireless router is set up for WPA2 and your PC/laptop indicates that, then I’d trust that it’s secured. If I recall correctly, a Glowforge will connect to a wide-open wifi AP, but it gives a misleading “could not connect to the unsecured network” message when trying to connect to the OLD/BROKEN WEP-protected network.


#13

xCSs2rQ

So, I rebooted everything AFTER I switched to WPA2 security. I used MULTIPLE devices. I did the “Connect to GF XXX-XXX” with my tablet which did the calibration once again. THEN I saw what I never got before: After changing to WPA2 and rebooting everything, I saw the padlock icon in front of my network, and I was prompted for my network password! That’s when the tablet’s software froze. I jumped onto my Windows 10 laptop, loaded the app and saw “READY” under my profile!! Wasting NO time, I grabbed my proofgrade maple and loaded up the Founder’s Ruler. Wasting no time also meant forgetting to open the window for the dryer vent…good thing for that “reminder” screen that popped up after I hit print telling me for the first time use not to leave the machine unattended, and I then remembered the window.

Thanks to everyone who responded! You all rock! I hope my hours of frustration helps someone else down the line.


#14

Glad to hear you got it working. Enjoy using your Glowforge!


#15

I’m glad you’re up and printing!


#16