Am I having to hit the print button twice?

Maybe there is something wrong with my vent, and I’ve been bathed in some hallucinogenic gasses, but I swear I now have to hit the print button twice in the GFUI to get it to print.

After preparing my artwork, I hit the Print button twice. I hear the head move, but the print button on the GF does not pulse. The Button in the GFUI gives a 0:00 estimate under it. Hitting the button again in the GFUI will process the print, and the button will pulse.

Am I the only one experiencing this, and if this is normal operation, what’s the reasoning behind it?

1 Like

Thank you for asking. What browser and browser version are you using? Have you tried using a different browser? When did this start happening? Thank you!

Google Chrome Version 70.0.3538.102 (Official Build) (64-bit)
OS 10.13.6 (17G3025)

As we have been told Chrome is the preferred browser, I have not tried Safari. :wink:

I think the issue started a week or two ago, I didn’t think much of it at first, so I didn’t start really noticing until well after it started.

I have had this since before the first time it was mentioned here, Sometimes when I am running the same settings again it does not come up and go away, but most times it comes up and goes away and you need to hit the print button a second time.

I just did a print, and it went the first time from Chrome. It hasn’t done that in a long time.

Has the issue been logged before? I did a quick search, and didn’t come up with what I found was a relevant result.

1 Like

It’s the same for me when using firefox…only happened a few time over the last year , but as of this month I have to hit the print button twice everytime I print…not a big deal but just wanted to add my two cents😁


I use Firefox and am having the same issue. Not always, but at random times.

Magically, it seems to have corrected itself.

1 Like

I’ve had this going on for quite some time now…and have been using Chrome ever since pretty much day one. Safari is my regular go-to, but Chrome is my dedicated GF browser.


It’s a new…uh…safety feature… Yeah! That’s the ticket.


I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!

If anyone else sees this, if you could take a video demonstrating what you’re seeing, we’d be happy to look into it.