Anyone else having issues today? Mine is stuck in "Centering"

Wondering if this is an issue across the board, or if it is just my machine.

I’ve been in the ‘queue’ with GF customer support for the last 30 minutes and still in position #4 which is frustrating. AND their customer service phone number just leads to a voicemail saying they basically don’t ever call people back.

Anyone know of a solution to get it working? My wifi is working fine. I’ve turned the machine on and off multiple times. I’ve refreshed and restarted my browser. Any other ideas?

Really disappointed in the lack of available customer support and second guessing myself on why I purchased it. Would love any support I can get!

1 Like

Your issues may be due to this.

(EDIT: This wont be your issue my mistake.)

I think it’s about 12 hours early for that. :wink:

In the meantime, this will give you some testing steps to take, so when support gets to you they will already have information they need to help you:

1 Like

lol you are right, My brain stored that earlier as being 12 noon for some reason. I think i was reading it at 2:30 in the morning tho which might explain things :stuck_out_tongue_winking_eye:


They don’t have a “customer service phone number”. Where that’s listed on the website it literally says “Finally, if you’re curious what our voicemail message sounds like, you can find out at…:slight_smile: They’re very upfront about it!

Hopefully one of the tips @geek2nurse linked to will help you sort your connection issue!

1 Like

I finally got it to work after 2 hours. Multiple restarts, unplugs, cleanings, refreshing browser, restarting computer, pulling tray in and out. Only to discover now that it’s printing, that it won’t accept any SVG files. I had to convert all of my prints over to PDF which is crazy because all of the SVGs worked yesterday.

And @deirdrebeth - yes, they are up front about their number. I just think it’s crazy to spend so much money on a product, and not be able to get a hold of a human.

1 Like

I’m so sorry to hear about the trouble with your Glowforge. I have followed up with your email about this as well.

Your Glowforge was able to connect successfully to your network, but it may be having trouble maintaining a stable connection. When this is the case, you won’t need to go through Wi-Fi setup again, but you may see an “Offline” message.

The most common solution to Wi-Fi challenges is to restart all the devices involved in connecting to the internet.

  1. Turn off the computer, phone, or tablet that you’re using
  2. Turn off your Glowforge
  3. Unplug your modem
  4. Unplug your Wi-Fi access point
  5. Wait one minute, then plug everything back in and turn them back on

If that doesn’t work, we have two more suggestions that often make a big difference:

  1. Improve the signal path between your Glowforge and your Wi-Fi access point
    Wi-Fi signals need a clear path. Remove physical barriers, and move devices closer together:
  • Move your Wi-Fi access point up high and make sure it’s in an open space. Avoid locating your Wi-Fi access point on the ground, under a desk, in a cabinet, or in a corner where its signal can be blocked.
  • Relocate your Wi-Fi access point closer to your Glowforge
  • Move your Glowforge closer to your Wi-Fi access point
  • Install a Wi-Fi range extender closer to your Glowforge
  • Run an ethernet cable and install a second Wi-Fi access point next to your Glowforge
  1. Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.

I hope this information was helpful. Please let us know if you are still having trouble.

1 Like

I appreciate your response, @chelsea - and replied to your email. The issue is not with my wi-fi. There is a strong signal (and it’s not far from the router) and the only other device connected to it other than my computer is my cell phone.

UGH… I am having the same issue., it is stuck on ‘centering’ mode.
is yours working now? Maybe I wont lose hope…:roll_eyes:

You cannot judge the GF connection with other devices. We have found this over and over again. If you haven’t done the troubleshooting steps already, I strongly suggest you do them. I actually suggest you take it even further and turn off your entire network by unplugging everything. Then start from the wall and plug in the modem and let it fully boot. If you have a separate router and/or WiFi access point, move to each of those in turn. Once they are fully booted, turn on your PC. Let it fully boot, and then turn on the GF. If you still find a problem, let support know what you have done.

These steps have been shown to resolve this type of issue pretty consistently which is why Support has asked you to perform them.

To reiterate, even though your PC/phone has a strong signal it doesn’t mean the GF does and it doesn’t mean your WiFi is working properly with the GF.


Mine took me 2 hours - and then I still have had issues on and off. Basically do all of the trouble shooting multiple times - it’s faster than trying to get a hold of someone in the customer service queue.
Clean camera.
Empty tray.
Clean tray.
Turn off machine, then turn on.
Unplug machine and plug back in.
Refresh browser.
Restart computer.
Test wifi connection (unplug, wait 10 seconds, re-plug back in - or move closer to machine).
Perform voodoo magic and do an interpretive dance.
Light everything on fire.
Find a new hobby.

Well, maybe those last few aren’t completely needed, but they are tempting.

Wash. Rinse. Repeat.

If that’s the sum total of your wifi testing especially if you do it after the turn off/unplug stuff then you haven’t tested your wifi so…


I’ve used the same wifi connection for two years, but it would not run the calibration process on it. I even bought a “wifi extender” and that didn’t help. Since I figured out that was the problem (and set up a temporary router to run the calibration), I’ve been back to using it (the same old connection) without issue.

The point is, restarting or having “a strong signal” doesn’t mean it’s not the issue. If you can set up your phone to be a wifi hotspot, you can at least eliminate that as the problem.


The link I posted up above has some useful suggestions in it that might save you having to light things on fire and such. :wink:

1 Like

I don’t know where I saw it, but when I had this problem, I cleaned the camera (and the glow forge). May have been coincidence but it worked for me.

1 Like

haha… i love it! We’ll see how legit my interpretive dance moves are soon! Thanks for your response everyone… cross your fingers for me, I need to STEP AWAY from the scene for a bit before I lose my mind and grab the matches :}

1 Like

I appreciate you mentioning this! My GF is back up and running. And this is the first time I’ve ever had this issue in the two months of owning it (no issue with wifi before). Hoping today was a fluke and I don’t have issues again.
And I’ll definitely look into it more if it comes up again! Especially if your extender didn’t help - but it might be worth a shot if that really is the issue.
Thank you!