Anyone else having trouble uploading SVGs to the Glowforge App?

This is when I try new files. The ones already in the cloud will cut. When I upload I keep getting this. All I’m doing is trying to upload simple SVGs

1 Like

I’ve had that a few times. I usually just quit the browser and reopen and it goes away. Hope you get things working again.

1 Like

I did try that, rebooted the laptop too, cleared cache; so far not successful. Hoping to sneak in new designs today while the family left the house to myself too :sob:

If it’s just me, may need to email support

All I can suggest is to make sure they are SVGs. (I’ve got a bad habit of trying to load up my base AI files.) :smile:


They are SVGs :cry: - pooh might be me then

Success! @Jules instinct was on the mark! It was a file problem even though I didn’t mistakenly try to upload AI files. The SVGs I tried to upload were invalid.

As a test, I re-uploaded other designs that I knew worked before After they worked I knew it wasn’t a GUI problem, it was a file problem. I realized the main difference was I am trying to use AI designs that I created before I even got the Glowforge.

I didn’t change any ways I was saving them with other work. It had something to do with the original designs. When I took the older designs, saved them in a new AI file first and then the files saved as valid SVGs. Not a AI expert but I guess those older files had something different in them.


Nope it’s me too. It just started coming about about an hour ago. I was cutting before that just fine. Then I tried to add new art and this message wont go away. Can’t load in any SVGs at the moment.

Let me clarify by “new art” I mean not new lol This is an SVG file i’ve used frequently, no changes to it.

Maybe it’s one of those annoyances that we all have to take a turn. I was fine today

You did by posting here…

1 Like

I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!