App stops functioning and shows just black canvas


#1

I didn’t have any problems with the app before. But now when I open a design, I can edit it for a few seconds before it stops functioning at all. I can’t click or drag artworks. If I zoom out or in the space will go blank.

I’ve tried different computers and browsers. It does the same if the glowforge is off or on.



#2

Try opening the lid and closing it again. See if the app will re-scan the bed.
If that fails, power cycle the GF


#3

I’ve tried that. It’s not about the bed not being scanned, it’s the app just stops working. Like I can’t edit any of the artwork. When I zoom in and out the canvas just goes black. Thanks.


#4

Is it happening with just one file or all files? What happens if you open a catalog design or a freebie like the Gift of Good Measure?


#5

What browser are you using? Chrome? Might need to clear the cache.


#6

So just played with it and here’s the weird thing. Using the open catalog I can edit those and the app works. As soon as I open an old file or upload something new it bugs out. To fix it, I can clear the cache and it’ll work for the pre made stuff.

I’ve worked with the previously files before and successfully lasered them.


#7

Can you zip up an example SVG of one of the files not working and upload it?

What program are you using to create your SVG’s?

Is interesting that it’s working OK on catalog files and giving you issues on uploaded designs. Might help narrow it down though.


#8

Yeah no prob. Using Adobe Illustrator. Thanks!

wood%20inner%20border%20heart


#9

That file has two identical vector paths lying right on top of each other. Try deleting one and ungrouping several times, get rid of the stray mark at the lower left side, and it opens without trouble.

(As is, it freezes up during the initial rendering.)


#10

How could you tell that there were overlapping paths? Not sure what happened there. Tried cleaning it up and it opens the file but still gets stuck. Sorry I’m new to illustrator, maybe I didn’t do a good job there. Thanks a bunch!!

wood%20inner%20border%20heart2

wood inner border heart2.svg.zip (1.3 KB)


#11

Not sure if you wanted one to be an engrave, and one to be a cut? Or… exactly what?

In this screenshot you can see where you have 2 groups (ignoring the groups within groups, that are just groups of groups lol)… both groups have an identical, filled black heart.

Not sure if that’s what it is supposed to look like. Discourse (the forum software) likes to strip some of the presentation attributes of SVG files - if you Zip the SVG up, it should come through just like it is on your computer.


#12

Oh okay added the updated file and zip in previous post. I just wanted to get that outline cut out. Is there a group break down like that in illustrator? Tried to google for it, didn’t find anything. Thanks.


#13

Your second file (the one you zipped) also had a lot of loose nodes and unjoined segments - had to delete those out of there as well.

I joined the open segments, deleted the nodes and this one should do whatever you want it to do - you can either cut it or convert it into an engrave.

wood inner border heart3.zip (978 Bytes)

The Glowforge interface gets confused and locks up if there are nodes and paths that have the same stroke color lying on top of each other…it just takes a little cleanup and they pop right in. :slightly_smiling_face:

We are looking into the Layer palette to see the extras - ungrouping enough makes them show up.


#14

Awesome, that was the trick and I see it in the layers now so won’t happen again. Thanks so much, what a relief. Thanks @jbmanning5 and @Jules!


#15

Thanks for the great research, @jbmanning5 and @Jules! We’re seeing this behavior too, and I’ve passed this information on to the team. I’m glad to hear you found a successful workaround in the meantime. I’m going to close this thread - if you have any other questions, please open a new topic.


#16