Art not showing in the design window


Trying to select a graphic from the premium service and it says, I don’t remember the exact wording, but the message that it’s uploading or the like to put the graphic in the design window. However when it’s completed the piece does not show in the list to cut or on the screen. I am able to place other graphics from the service. I will attach a screen shot with the piece in question circled.


Works on my end…

Just clicked on it and there she is… Just choose to engrave or cut…

Interesting. Made me try it again and this time it worked. Maybe just one of those strange problems with something. I couldn’t get it at the original post but could add others to the design. This time I had a different design open with just some cut outs so I tried to add it there and it worked.

Thanks for trying which had me try again.


Maybe you weren’t holding your mouth just right :wink:


I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!