Bench style business card holder not loading image

Has anyone had a problem with the bench style business card holder not loading? I have tried to open it from my dashboard several times and no image appears. I have gone into the catalog to try and load it again, but have to select open my design and get the same result. I have reported it, but wanted to share here in case anyone has had the same experience.

No - but for any :glowforge: provided design you can click on the 3 dots menu, click Design Details, and then Reset Design and it will refresh to base.

Keep in mind that the GFUI saves whatever you did last, so if you move everything off to the side, or delete items, that’s what it saves. Before you leave a design where you’ve done either of the above, you can hit Ctl-Z to go back. If you forget on a design you uploaded yourself you’ll have to re-upload it from scratch.

I will try to reset the design. I meant to upload the image I just added as well. It does not even show it on the left side and says no artwork. I have never had that happen before. This is my first attempt at cutting this file as well.

Oh no, I’m sorry you’ve hit a snag!

I’ve downloaded the Bench Styled Business Card Holder and was able to successfully load the file without trouble. The good news, is this means @deirdrebeth is on the right path.

At your earliest convenience, open the design, click the three-dot icon, then Design Details, and choosing “Reset Design” to remove all changes.

Let us know if this gets the file back for you!

I don’t know where the 3 dots are to reset it?!?! The design will not open and that is the issue.

Screen Shot 2021-01-09 at 9.44.48 AM Screen Shot 2021-01-09 at 9.45.01 AM

The three dots are at the top of your screen

1 Like

Oh haha, did not even think about those 3 dots, I was thinking it would be on the actual image of the design. Thanks for the help, that fixed it.


Thank you for updating us! I’m so glad to hear that resetting the design has helped to resolve the snag you were experiencing. I’ll close this thread for now, but please don’t hesitate to reach out to us directly at in the future if you run into any more trouble. We’re here to help :slight_smile: