Beta 4000 speed

Please change the default assumption for manual settings back to the original speeds and let us opt in to 4000 speed. I know it is my fault for not noticing but I’m re-running jobs because it didn’t engrave dark enough as it was going too fast or messing up on jobs because it is skipping. This is a busy season for many users and to have the speed automatically default to 4000 when projects are loaded is not good service, especially when there are so many known issues with it and it is in beta testing. Thank you.

Default PG settings have not changed with the introduction of higher speed engraving.


I rarely use default PG settings. I’ll edit my post.

Do you save your settings? Would help you get around this if you are using the same materials over and over.

Yes, I have a lot of settings saved but I’m doing a lot of experimenting on different materials and the list of saved settings is quite long. I’ll pay more attention. I’m burning the candle at both ends right now. I think this is happening even with my saved settings. Thank you for your suggestion.

I’m so sorry to hear that you hit this snag.

We’re currently investigating this behavior. I appreciate your feedback, and I’ll make sure it gets back to my team.

I’ll close this topic for now, but please don’t hesitate to reach out to us in the future directly at if you run into any trouble. We’re here to help!