Black strip

ok got my “new” glowforge and it didn’t work. first I was told it was my cable service. so i fixed that and added boosters. now they say it is the “black cable” and during the time to upgrade my cable service it went out of warranty. but, I was sent a new cable. so, i put it in. and it was a #^%$ to do. it still does not work. so I ordered 2 more in case i damaged the first replacement. if anyone has put one in how did you do it. the film they show you , the connections are out of the cover and not installed!

Haven’t had to do one yet, but they have the instructions for it here:

1 Like

Replaced one following instructions. Solved the problem.


have done that many many times. the video show the connections out of the lid!!! so, what are other doing to make this simple fix go a little easier?

Hi @redbrown02. I’m so sorry to hear that you’ve run into some installation trouble after receiving the replacement black lid cable. I understand that you’re running into trouble with the connections, and wanted to see if it was any specific connections to try and give you some added suggestions to help. Feel free to take any photos as well of any problem areas, or what has been tried, and we can continue to troubleshoot from there. Thanks!

1 Like

FOR ME i HAVE FOUND THERFE IS NOT MUCH ROOM to put the connection in and is very aggravating for me. was kinda hoping maybe someone who has put a few in found a “trick” that makes it easier for them than the conventional method used. It is posable in the process i damage the strip some how. so i will buy a couple of extra’s and see if that is the case.

I’ve only done one on my machine but it went pretty smoothly. You just have to be very careful to not let the ribbon touch the glass until it’s lined up perfectly. Maybe a helping set of hands would be useful. Once the thing touches down it sticks hard and fast.


I know the lid cable can be a little tricky to replace due to the connections being small. You mentioned one of the connections might have been damaged. If you can please post the following photos, we’ll be happy to take a look and see if anything looks damaged or out of place. Sometimes it can just be that one of the connecters is seated a little crooked and not making proper contact. Once we have the photos, we can review and provide next steps. Thank you!

1 Like

Hey there @redbrown02, its been a few days since we last heard from you so I wanted to check in. Are you still having trouble with getting the lid cable attached? Since you mentioned a possibly damaged connector last time you posted, I’d like to get photos of the cable connections so that we can determine best next steps to assist you. Could you please post photos like the examples I mentioned in my earlier post?

1 Like

I have yet to receive the new cables i have ordered so i can determine if the cable was bad. as of yet the machine has yet to work. if it does not work after these new cables come in I am just going to box it up and send it back. so very disapointed. this was going to supplement my retirement!
Brian K Helms

Take photos of the setup now. Don’t wait for new cables. They need to check the boards, not the cables.

Hi @redbrown02. We completely understand any disappointment this has caused, and would love to help you get this resolved so you can get up and printing again. As @MorganW and @Jules mentioned, feel free to send us any photos of the connections, especially the connection that may be possibly damaged. This can help us better see what may be occurring and help us decide the best next steps for a solution. Thank you.

I see we’re assisting you in another forum post, I’m going to close this one to simplify our communication.