Brand new Glowforge Pro - Unable to Start a Print. Stuck on "Centering" or "Homing"

Help, please.

I followed every piece of the unboxing/startup to a T. Got to the point I opened up the app and went to do my first “Gift of Good Measure” with the Medium Draftboard proofgrade material that came with it.

It was stuck on ‘homing’. (I heard some clicks with no movement).

I turned off my computer and restarted it, turned off the glowforge and opened up the lid. Moved the arm back gently. Checked connection to the head to make sure it’s in tight.

Closed lid, turned on machine. “Centering”. And now, about 10 minutes later - still ‘centering’.

I’ve repeated that twice so far - and so far no luck. It keeps getting stuck on centering. I did see the arm move and the head moved to the middle this time - but the 10 minutes after it’s done nothing.

Any ideas? I tried to call support but…well, you know. Had to leave a message.

Those are symptoms of a bad lid cable but as the machine is new (?) it might be a loose connection.

The troubleshooting pages have detailed pictures of which connectors to check - which support will ask you to check anyway. It’s possible re-aligning the cable to a connector might fix it.

1 Like

Thank you! I’ll check that and see. Yes, brand new shipped from Glowforge, arrived yesterday. I’ll report back if I’m able to fix it with the troubleshooter - thanks for the tip!


Ours did the same exact thing. Finally got in touch with someone at Glowforge. They said they couldn’t fix it on their end and that we would have to replace it. They sent a refurbished unit to replace a brand new unit that never cut/engraved anything. Just unboxed the one they sent to replace it and still can’t get it to connect…very aggravated. Just sent email to support. Waiting for a response.

Our button was staying an amber color. The camera was not detecting/recognizing the proof-grade material we had in the machine.

Thanks. Yea, I got nowhere too. I’m with you, I’d be irate to get a refurbished for one that was literally just received. I understand if it’s a few months in, but just unboxed? Ugh. Was debating getting a glowforge for over a year, finally decided on it just due to space constraints. The fact I can’t get ahold of anyone when I need it is not helping my opinion of glowforge right now. Now guess I get to see how long support takes to get back to me.

You might try centering the head directly under the center camera (then closing up the lid etcetera) and turning the machine on. The first time the machine is turned on It has to do a lot of work downloading the latest files etc so I would let it be for an hour. Normally it does not take as long, but the first setup ever has a lot to accomplish.

1 Like

Just for fun - try a different wifi network? (like phone hotspot if another isn’t available) I don’t get connection or startup errors often but when I do it’s always the wifi (which is weak in my GF area).

1 Like

Thanks! Tried that and tried letting it run for 30 minutes. So far no luck, but I appreciate the ideas.

1 Like

This is what my screen looks like. I’m not getting a camera image - am I supposed to? (I really, really want to love Glowforge. This was just my frustration seeping out when I have a brand new REALLY expensive paperweight.)

It might be a wifi connection issue.

Open up your router config and find the 2.4 GHz wifi channel settings. Test the GF with the router set to channel to 1, 6, and 11. (You are probably already on one of those, so just test the other 2.)

It may indeed be a cable but this test is easy and harmless.

2 Likes

Thank you!! I will give that a go tomorrow. I appreciate the idea, willing to try anything that won’t void my warranty.

Heard back from support today and they are going to be sending me a new unit. Improved my mood significantly - I am honestly relieved to have heard back the same day.

Replacement Glowforge arrived, and it’s a completely different experience. Phew. Finally got my first cut, 8 days later!

Thanks everyone for the insights!


2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.