Bug report: enclosed holes are treated as filled


#1

I’m running into an issue where filled curves (intended for engraving) are filling space surrounded by the curves, and this is a problem. I just recently started to notice this in the past few days, and I’m not doing things differently than I have been, so I suspect this may be a new bug.

Take for example this donut shape:

The Glowforge UI renders it enclosed, and engraves it that way too:

I can work around this by rasterizing when I export the SVG, but I would like to keep the whole thing vector and let Glowforge rasterize it at the time to engrave.

Here’s the SVG of the donut shape:
test


#2

What’s your design software?


#3

Affinity Designer. I’ve opened the SVG in a number of other pieces of software though, and they all correctly render the hole in the middle. Even the SVG at the bottom of my post is displayed correctly by Chrome.


#4

when it’s coming into GFUI, it looks like two circles that are both filled with grey and with black outlines.

can you upload your zipped SVG here for us to look?


#5

That tiny donut is the SVG, but here it is zipped.

test.svg.zip (1.1 KB)


#6

Size that down and print on a piece of scrap. I often get stuff that looks that way but prints fine.


#7

when i open it in illustrator, it shows as two filled objects.

Capture


#8

I use AD, also. I just opened your SVG and it looked fine to me, but it loaded into the UI just as you said/showed. So, I made one myself…with a filled black circle and a second circle, no fill with a black stroke, then subtracted it out of the filled circle. I looked exactly like what you had made…and unfortunately, also loaded into the UI also exactly like it did for you. Weird.


#9

It doesn’t show in AD like this…I shows as a black donut shape. Maybe the ‘bug’ is in AD?


#10

maybe a setting in svg export?


#11

Hmm thanks @shop, I tried an online tool called Janvas and it also rendered it the way Glowforge does. Guess it is an AD issue. I’ll play around with the export settings.


#12

It’s a perfectly valid SVG. Every web browser renders it fine.

It’s just yet another example showing that Glowforge doesn’t support both fill rules. (There are two; even-odd and non-zero, both of which are useful and commonly used.) It seems that Illustrator also has a similar bug.


#13

I don’t think so…I did it exactly the same as I always do. I have a pre-set made up for the GF so it pops all the settings in automatically.


#14

Adobe illustrator doesn’t render it right. neither does the tool @endotronic used (Janvas).

so it’s not just GF.


#15

I tried changing the Winding Order in AD and had no luck with it.

I then opened the file in Inkscape and simply re-saved it, and it came in solid in the GFUI.

Then I broke the paths apart in Inkscape, ran the “Difference” command to cut out the hole in the center and re-saved the file. This time it worked in the GFUI.


#16

Thanks for letting us know about this. I’m sorry you ran into trouble, and I’ve passed your report on to the team.

If you run into this issue again, please try the workaround @mpipes mentioned:

Could you please let me know if this helps?


#17

The problem is that the SVG uses “fill-rule:evenodd”.

Glowforge doesn’t yet understand this fill rule. It only understands fill-rule:nonzero–and that’s the one where winding order matters.


Bug: SVG fill-rule:evenodd not supported
#18

I have run into the same issue. I’m also an AD user, and it has been working fine for me up until 1-2 weeks ago. All of a sudden, enclosed holes have been solid in the GFUI - but I know they appeared correctly a couple of weeks before.

I haven’t updated Affinity Designer recently (the date on the app is 10/15/17, before I even got my GF), and the same exact process worked for me before, so I believe the change has been in the GFUI.


#19

If you’re using AD, change the Layer->Fill Mode to Winding and use Subtract instead of Combine to create the donut.

EDIT: Nevermind. I thought my test worked, but I must have done it incorrectly. This information is incorrect.


#20

@oscar We try to keep to one topic per post in the Problems and Support section. Can you create a new post with this question?

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.