Build a snowman family ornament will not open

I have premium and snowman ornament is stuck on rendering design. I have tried different browsers. Tried to delete but i can not. Attempted to open from catalog still did not work. Please help.

It opens okay for me, hope support can help you.


Most likely support will have to delete and reload it from the back end - but try either clearing the cache on your browser or a different browser - then open something else (Gift of Good Measure) - and then try it again. Sometimes the browser will get stuck in a loop.

All of my others designs work and I have used this design before many times. Super confused. Deleted all history and caches. Tried using my phone.

Hi @focus1st. I’m sorry to hear that you ran into some trouble opening a design in the Glowforge App. It looks like we are working on this through email and phone currently with you. To avoid any potential confusion with multiple opened threads, I’ll go ahead and close this thread. Thank you!