Calibration Hell


#1

So last night I finished a print, thought I’d do another quick one before bed and when I changed materials the bed image wouldn’t refresh and I’m stuck in calibration. I turned it off and let it sit overnight. When I woke up this morning it was the same issue.

I have:

Restarted everything, from modem to laser, in order
Moved the head under the camera(with power off & unplugged)
Cleaned everything (with power off & unplugged)
Let it sit for >30 minutes while “calibrating”
Held The Button for ~10 seconds until it turned green and reconnected it to the wi-fi.
Attempted a print from my tablet AND my phone. Nada.

The room is air conditioned. It’s not overheated. I’m at a loss. Any ideas? I’ve had this happen before but restarting my browser fixed it last time. No dice this time.


#3

I don’t think we’ve ever seen a clear answer from Support on this. Last time it happened to me it lasted for some hours (where I drove myself crazy trying all sorts of things like resetting my router, even connecting to another WiFi, etc…) and then hours later, after I’d given up, it magically worked again like nothing was ever wrong. They seem to indicate that there’s some issue with the user’s WiFi, but everybody always explains that every single other device works great. My suspicion is simply that the WNIC in these things suck and they flake out sometimes. I have no proof of that other than the countless “Stuck calibrating” threads on this forum.

Good luck with it though! You’ve made some great things and I look forward to seeing that continue!


#4

Try cleaning the camera lens. If the lens is dirty, the forge sometimes has a problem focusing on the logo, which results in being unable to calibrate.


#5

What’s a WNIC?? For learning purposes.


#6

The camera lens is clean, it’s part of my cleaning routine.


#7

Sorry. Wireless Network Interface Card :slight_smile:


#8

WNIC = Wireless Network Interface Card


#9

AH okay, thanks!


#10

I’ve ruled out my wifi being the issue. I set up a hotspot on my phone and reset the GF wifi to it and the issue is still there. I could understand if it was my home wifi as comcast has been horrible the last week but my phone signal is rock steady.


#11

Did you try rebooting your router? (Generally just unplug it from the power source for a couple of minutes.) Unplug the Glowforge for a few minutes while you are doing that as well.

While that’s going on, log out of the app on all devices. Clear the cache on the browser. Then turn on the machine and let it run the startup calibration without turning it off or signing in to the app.

Only open the app when it’s done.

(Worth a shot.)


#12

I did try that, yes.

I didn’t think to clear the cache. Lemme try that.


#13

Restarted the router again, cleared the cache, tried to get it to calibrate sans wifi at all, cleaned all the lenses AGAIN just because, cussed a little, might have shed a tear. Contemplated throwing things at it. Still not working 24 hours after the initial issue and of COURSE I get 2 custom orders today that need to be printed asap. I need this fixed.


#14

Er, is that even possible ?
:upside_down_face:


#15

No clue. Probably not. But nothing else is working and I’ve got deadlines so


#16

I’m curious about your logs. Are you willing to extract these for learning purposes? I have the same issue and I’d like to cross reference the log errors. Here’s how you extract the logs from your glowforge:

Reboot your Glowforge once more and wait about ten seconds

Hold down the button on your Glowforge for ten seconds, until it glows with a teal color

Your Glowforge is now broadcasting a temporary Wi-Fi access point. Connect your computer to “Glowforge XXX-XXX” (from your Wi-Fi Settings)

Visit the following URL in your browser: http://192.168.192.1:3000/logs/zip

A .zip file should download to your computer

Reconnect to your usual Wi-Fi network and email the .zip file to support@glowforge.com

Open the .zip and find the most recent file. You can open this file with a text editor (wordpad/ textedit/ etc). You’ll find a lot of lines of information. Do a search for the word “error” and see what comes up. My errors are lid camera related and sometimes coolant pump. I’m curious about yours.

Good luck and I hope support is quicker to reply and act to you.


#17

Thanks for reaching out. I’m so sorry to hear your Glowforge is having trouble calibrating.

I’m looking into this now, and I’ll be in touch as soon as I have more information.


#18

Everything works until the actual download. The file says it completes the download. I go to open it and it says it can’t decompress it because it’s still being downloaded. Even though it says it’s done? Confusing.


#19

Definitely not. It needs to talk to the server.

Successful calibration requires:

  • That there’s nothing wrong with your machine (including anything from mechanical failures to a dirty lens to a broken wifi antenna)

AND

  • A solid connection to the Internet. Your home Wi-Fi may seem ok, but what gives you 5 bars on a laptop might not necessarily be working for the embedded computer in the Glowforge.

AND

  • The Glowforge Cloud is up and running. We have no real visibility into this, so while everyone’s first guess is that it’s something with your machine or environment, maybe there’s something wrong on the backend. We’ve seen that the Glowforge store often experiences extended periods of being broken for certain subsets of customers, which suggests they don’t do any black box monitoring. Maybe the cloud service falls over for customers in a certain region or whose accounts are stored on shard 13.

AND

  • Successful image recognition. It appears that calibration involves machine learning, and can be confused my too much light, too little light, shadows, objects on the bed, dust on the print head, etc.

Most of the troubleshooting steps people recommend are trying to rule out as many of those variables as possible. Unfortunately, most of them are a shot in the dark. It would be great if the system were designed to provide more clues when something goes wrong, because calibration failure is a popular topic around here.


#20

Clues do exist, but they are just that - clues.

That we really can’t verify, unless you want to dig into your logs to investigate. This may not be the most viable option for a lot of people, because it contains a ton of information (some of which could look scary but isn’t), spread out over a lot of different areas. It can be fairly ambiguous - one root error can lead to other errors, and then a person thinks they have a million errors.

A good similarity to this are Check Engine light codes on vehicles… I’ve seen a lot of people waste a ton of money and time and effort chasing down fixes for a Check Engine light code trying to fix it themselves. Just having the code doesn’t tell you what’s going on - it points a mechanic on where to go, so they can test systems further to make a diagnosis.

This is definitely a tough one to diagnose… so much can happen. DHCP not assigning IP, same addresses being assigned to devices, etc. On top of that, the connection seems somewhat fragile if I want to interpret what support and Dan have said in the past, as far as interference, network conditions, etc.

I’m not sure exactly what drives statuspage.glowforge.com — if all of the data is dynamic or just manual input/changes. I’m guessing a combination of the two.

This is where clues come into play.

What the machine is doing while it is attempting (or needing) calibration can point you in the right direction.

If it’s not doing anything, it could be: a network issue (local or external), or a mechanical issue (eg.,failed camera; I have seen one persons logs where the camera just failed)

If you’re getting a white light, it’s receiving data… if it’s not doing anything, it could be a mechanical issue (not able to initiate motion). If it’s hunting around and will never finish calibration, it indicates more of a problem with the camera not being able to identify the head (something obfuscating the bed image taken by the lid camera – dirty lens, a ton of overhead light, holes in the material etc [which all seem to have gotten quite a bit better over time, hence the machine learning])

Probably (definitely) more variables and issues than I list above - but clues are available to a degree if one knows what to expect, look for, or where to look.

Ultimately, I’m not sure how much information should be just outrightly displayed, and how it all should work. I like information… love it even… but there is also a point where even with the information, you’re still going to be waiting on support for something you can’t fix yourself.


#21

Thanks for your patience.

It looks like there may be a few things causing the calibration trouble.

Please check the printer head lens by following steps 1-5 from these instructions: https://glowforge.com/support/topic/cleaning-service-and-moving/cleaning#things-that-need-wiping

If you see anything unusual, please take a photo of it and attach it to your reply.

Also, I’ve made a small change on our end that should clear this up. Could you please do the following for me so that the change can be applied?

  1. Turn off your Glowforge.
  2. Open the lid of your Glowforge.
  3. Wait at least 10 seconds.
  4. With the lid still open, turn on your Glowforge (please do not touch the button on top of the Glowforge - only the switch on the back).
  5. Once the Glowforge is on, wait around two minutes, keeping the lid open, so it can download and apply the necessary updates.
  6. When the update is complete, your unit should reboot on its own. When this happens, go ahead and close the lid.
  7. Your Glowforge should proceed to connect and calibrate, then you’re ready to print!

If at any point during these steps, the button on top of your Glowforge glows with any color other than white, or if you run into any other trouble, please stop and let us know.


Calibration of Death