Camera out of focus, no flash and unable to read QR

My lid camera has all of a sudden gone out of focus, and the image is very pixelated.
It will not read the QR-code, when using proofgrade material.
I’ve tried cleaning the camera with Zeiss wipes, and ensured the selected material thickness is correct.

I’ve also tried to place a mirror under the camera, to see if the flash was working, but I don’t see any light coming from the flash.

I’ve attached a screenshot so you can see for yourself.

Thank you.

Best regards


Uh-oh. Yeah, support needs to look at that one, and the picture helps a lot.

Out of curiosity, can you turn the lens in the lid camera? (Don’t twist it hard, just a gentle touch to see if it’s loose.)

Good luck!

YES, I could turn lens, seemed that it had come loose? Tightened it, and the image became worse than before. This must a be noticeable fault I think.
Excited to hear how to solve this, and if it can be fixed without replacement?

Thanks for your input.

Last I heard that camera focus is set at the factory and glued into place. It does seem like a lot of effort to ship the whole thing back just to twist the thing back into position, so maybe they have a do-it-yourself procedure now. You’ll find out soon enough, let us know what happens.

(If it were me, and I’m not saying this is advisable… I’d just turn it a little bit at a time and see if I can find the point where it gets back in focus)


Thanks for your advice.
I would say, they need to use better glue. This unit is less than a year old.

Yeah, unfortunately, the lens is supposed to be glued into place, because that focus is part of the calibration process for placement alignment. They might prefer to call it back home for repair.

Sorry for the bad news. Maybe Chris is right and they have a remote calibration process worked out now.

My last replacement took a week, to Denmark. I can live with that, if that’s the most reliable solution.

1 Like

My guess, and I’m just guessing, is that fixing the lid camera focus is unlikely to ruin your machine’s calibration. Especially if what happened is just that the lens came unglued and it only needs to be refocused. Those cameras have a threaded lens that just screws in and out, so putting it back where it was should be fairly straightforward to do without altering any of the critical alignment parameters… IMO. As opposed to if the camera fell off the lid or something, where you’d never get it back to the right place without the magical factory calibration jig.


I agree with Chris, the camera (in my argument from ignorance) is only one aspect of the calibration.
The machine worked fine, and the camera got bumped or rotated when cleaning it. Everything else remains the same, so it would seem repositioning the lens focus would restore functionality.
Personally, I wouldn’t be able to box up my precious without trying. The issue is documented here, and I cannot fathom that my slightly rotating that lens would void the warranty due to a problem that already existed.

Then again, I am in no position to make that call, I’m just saying what I would do if I found myself in that circumstance.


What makes me wonder is those who have seen their camera image get worse without any obvious loosening of the lens. I have a bit of that, and a big dust blob too.

We need to be able to calibrate out in the field. This procedure of having to send the unit out for calibration or a blurry camera focus is incredibly ridiculous.

I’ve seen this quite a few times on the forum and I assume the thread will end with a glowforge rep saying they are sorry to inform you that it must be sent in.

In PRU days it wasn’t glued in place and my PRU was blurry so they eventually had me turn the ring to bring it into focus. I assume when they tell you now that you should not turn the lens is because it is glued, and the force required to crack the glue would damage the lens, but obviously if the glue has failed, that’s not an issue right now. The trick is of course figuring out the focus, since there is no easy way other than turn it, close/refresh trial end error to get it back. I also guess that when the QR is in focus you have it right as far as focal point. You may not get it exactly at the factory setting, but given that is 0.25" alignment tolerance that’s hardly an ideal to aspire to.


Obviously wait for support to reply. But as @henryhbk said, in the PRU days I got a couple units that were out of focus out of the gate or slowly got out of focus.

What I ended up doing was setting the glowforge to a known material (proofgrade) and placing my ISO 12233 chart on top to get it back in focus. That corrected a lot of issues. (i.e. detecting QR codes and vector placements.)

But in this day an age, Glowforge is doing optical foo at the factory and using that calibration data to help the Google ML do what it does and possibly needed for features like Snapmarks.

So manually adjusting could be bad.


@chr_hermansen, I see your image quality has improved in recent prints.

Could you please let us know if you’re still having issues?

I’ve had the same issue since about a week after I got mine messed with got it better and worse finally gave up as long as it can read the qr code but if there is a better way to get back into focus I’m all ears

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email