Can’t connect to WiFi


I tried to hook up my GF for the first time today and it won’t connect to the WiFi. I’m not a techie person and can’t figure out why it won’t connect. I’m thinking maybe it has something to do with my internet security? It said to try to connect to something I cant remember… or something and my internet security said that the site was not safe and wouldn’t proceed. If it wouldn’t go to that site, I’m thinking the firewall is in the way? Could that be it? And if so, if I take the firewall off to connect… isn’t that bad? I use McAfee for protection. Any advice would be appreciated!! Thanks!!

Take your firewall down and see if it works. You can also try using your phone as a hot spot to connect.


Ok, I will try that today. Thanks.

Hello @sarahpassotphotograp, I’m sorry to hear you’ve had a rough start getting your Glowforge connected.

I extracted some logs from our end to investigate, and it looks like your unit is connecting to your network and to our servers successfully, but still needs to download and apply a necessary update. This may take several minutes.

Could you please do the following for me?

  1. Turn the Glowforge on (only use the switch on the back - there’s no need to push the button on the top of the Glowforge for these steps)
  2. Wait about three to five minutes
  3. Let me know if you see or hear any activity from the Glowforge.

If the Glowforge reboots and the printer head begins to move, please sign in at If you don’t see any motion or the Glowforge rebooting after ten minutes, please reply and let me know.

Thank you!

Thank you!! I will try this in about an hour when I am able to. I appreciate your help!

Ok, I turned it on and it moved around. It seems to have stopped now but the light is not glowing teal. Should I press it?

It is a good sign that the button doesn’t glow and the head moved. If you go to, does the machine show connected or offline?

So I pushed the button and it glowed, but I still can’t connect. It says it’s connected but no internet. I’m going to restart my modem but my phone is working just fine. I don’t think the modem is the problem. I also turned off my firewall. I’m frustrated :frowning:

Hey @sarahpassotphotograp, It looks like the update was successful. Unfortunately, I need to ask you to go through the setup process one more time so your user account can be properly associated with the Glowforge. I’m so sorry for the inconvenience!

Could you please go to and follow those steps again?

Fair warning: you’ll probably receive the “Glowforge Didn’t Connect” error again. Don’t worry if that’s the case! Simply turn the Glowforge off, then back on, and wait for the calibration process to complete (about two minutes). After the head stops moving, log in at and let me know if your account is associated and the Glowforge shows up in the printers list.

Let me know how it goes.

Ok, will do

Same thing. It connects but says, “No Internet, Open.”

Oh wait. We might have something here.

1 Like

I got it!! Thanks for your help!!!

1 Like

@sarahpassotphotograp That is great news! I’m glad to hear you’re connected now. Please email us at if you need anything else, we’re happy to help!

Happy printing!