Can’t upload files ...again

Have tried from my phone and laptop. Are we experiencing another problem on the GF end? Anyone having this issue?

1 Like

No problem here with mine. Are you dragging and dropping on the Glowforge bed or using the upload button for a file saved on your phone. Are you getting any error message?

1 Like

Happens all the time!!! Clear out your cache sign in again.

Hello @sarahpassotphotograp,

Thanks for reaching out to us. I’m sorry to hear you’re having trouble uploading your design files. I can confirm that we are not currently having any trouble on our end.

I took just took a look at the logs for your unit and can see that you’ve been able to print since posting. Are you still running into upload trouble? If so, does it seem to be with a particular design file or all files?

Yes, still can’t upload the files I’m trying to print. I’ve cleared the cache, tried to drag and drop and also upload from the interface and my phone. Nothing is working.

FWIW, no issues for me either. Do you want to share a file or two here and I can see if they load for me?

Thank you for letting us know, my apologies for the slow reply.

If you’re still having trouble could you please post the file you’re running into trouble with? We’ll be glad to take a closer look. If you’d like to share privately, you can send the file to

I’m sorry I have been so lax with this problem as well. I’ve got a ton of orders that I need to fulfill before I tackle this. And then there’s life… lol. I guess I will email support with it when I have the time. Thanks for responding, everyone!

Thanks for the update. No worries, we’re here for you whenever works to send the file.

Could you let me know if you would like me to leave this post open for a while longer? Or I can close this post, and you can send us the file at at any time.

You can close it. Thanks.

Sounds good, I’ll go ahead and close this post. When you’re ready, we’re here for you at Thanks for letting me know!