Cannot select objects. Cannot select objects once unselected. App update issue or something

Something changed since yesterday (working fine yesterday) as I can not select objects in app. Highlighting an object wont select it, clicking on an object wont select it.

Tried app in multiple browsers, multiple laptops etc. I can only guess a bad update went out to the app.

I have a $6000 paperweight on my hands basically, and this highlights why the glowforge needs an offline software that isnt dependent on glowforge servers.

I don’t mean to offend anyone, however I have VERY upset. Deadlines don’t care if I am having issues, which I obviously currently am.


I am experiencing the same thing. I messaged support last night, but haven’t gotten a response yet.

1 Like

I’m having the same problem! Sounds like it must be a pretty widespread software issue. I’ll email support now as well.

I am having the same issue. I cannot select or move items in the glowforge app. I have tried using multiple browsers, along with using both new and old files. If anyone has any other suggestions I am all ears.

Having the same problem today

Same here. It’s BS because I have work to do. Man, tbis is infuriating

1 Like

You can hit Ctrl+a and it’ll work that way


If only I wanted to select all…

I know! Only solution I have found :sleepy:

1 Like

Try using a selection box instead of clicking directly on your artwork. If you make the box larger than the file (by a significant factor), I’ve had good luck getting it to recognize their is an object and allow me to manipulate it.

Ctrl+a def is a nice workaround! Thank You!

Judging from the responses the other method of selecting or dragging over to select an object seem to def be app related.

Hopefully they fix it soon. Id still rather have an offline software solution. the browser based app seems like a huge weak point.

Thank you! That workaround helped!

OMG i’m so glad i’m not the only one. Wasted so much time trying to ‘fix’ my file only to not have it work multiple times.

My husband just asked if maybe selecting objects is now a premium feature… :sweat_smile:

1 Like

UGH - same - this is annoying!!

Same problem here.

LOL! Would not surprise me at all.

1 Like

Hello there,

I’m so sorry for the trouble. We’re seeing this, too, and the team is looking into it now.

We’ll follow up as soon as we have more details.

Warm regards,


Glad that Staff seen the issue… I have 60+ orders which I have to ship by tomorrow lol…

CTRL+A you can select your artwork again. But if you have multiply artworks I recommend to place them in a right place before you drop another artwork…

Or when you guys select them all hold “SHIFT” key and click with left mouse on artwork to deselect it to move another artwork… The struggle is real :smiley:

1 Like

I have quick solution. Drag select from a distance. Go fsr right, below or to the left and drag straight up down or.accross. then duplicate your art if need be and apply your art. I’m using my laser perfectly with this. S

Seems you need to drag far away from your artwork.

1 Like