Can't add text

I’m trying to design a print file and when I click on the T to add text it just sits there and spins. It’s never done that before. I’m not sure what to do next.

You should be able to back out to the Dashboard, then reopen the file, and hopefully it will clear the stuck command.

Maybe. (I haven’t seen it but it’s the first thing I’d try.) :slightly_smiling_face:

This is a known issue, no resolution was ever shared.

I’m hoping it will be fixed soon.

Unfortunately that doesn’t work. I’ve tried clearing my internet cache too. Everything else works. I just can’t add text.

How much text are you trying to add? I’m wondering if it’s just taking a longer time because it’s a lot of text or if it’s hung up somehow.

If it’s a lot of text, you might want to set it up as a raster file in something like Gimp or Photoshop (or Inkscape) and bring it into your opened file for engraving. It requires less processing time.

If it’s hung up, you can try closing the app, clearing the cache, and then reopening the file. (Oops, I’m on a small device…I see you tried that…maybe turn off the machine )then restart.

1 Like

I’m sorry that you’ve run into trouble with the new text feature. Thank you for letting us know about this. Our team has been able to reproduce the issue and is continuing to investigate, so I’m going to close this thread.

If you run into other trouble, please post a new topic here on the forum or email us at and we’ll be happy to help!