Can't drag to rearrange engrave/cut layers

Today I can’t seem to drag to rearrange the engrave/cut layers. For example, I upload a new file with a cut and an engrave design on it. It defaults to engraving first then cut, but I want it to cut then engrave. However I cannot rearrange them like before. Does anyone else have this issue?

Try a different browser. I used to have that problem and switched to Chrome which has worked for me since.

I just tried both Chrome and Edge and I still cannot

oh, turns out I have to click in a very very specific spot on the layer in order to drag it around. Is this a new UI update or something?

edit: it seems that you have to click on a very specific spot on the top or the bottom in order to rearrange. once you select the top spot, you can only go up and not down. this is pretty inconvenient and the old UI was fine?

Short screen capture:


Hello @lazurin. Thank you for reaching out and posting the video. There haven’t been any recent changes in the app that would cause what you’re seeing. I am currently using Google Chrome and am not able to recreate this behavior in my app.

If you haven’t already done so, try clearing your browser cache and restarting your browser to see if that fixes the issue.

1 Like

Hi @lazurin. It’s been a while since there’s been any activity here, so I’ll go ahead and close this thread. If you run into any further trouble or questions, feel free to create a new thread, or write us at and we’ll be happy to help. Thanks!