Can't Select the Air Filter Tab

Hey! So I was able to receive my new (refurbushed) Glowforge (mine had issues and they sent me a refurbed one). I set it up and it works great, however, I can’t seem to click on the tab to turn on the air filter connection (it’s one I purchased from Glowforge). The selection is there, but it isn’t highlighted and I can not click on it to turn it on. Any suggestions? I have turned it on, shut it off, unpluged the air filter, shut it off, plugged it back on, turned it on. It turns on, but I can’t override the internal one on the machine…it makes SO much noise and the smoke comes out even more. Not sure what else to do…

Support will have to fix that. For some reason some machines are shipped with that disabled.


Got it! Thanks for letting me know instead of me freaking out…lol. It was fixed when I woke up this morning. <3


I’m sorry for the trouble when getting started with your replacement Glowforge. I’m glad to hear that the issue is resolved and that you’re now up and printing! If you run into trouble again, or have any questions for our team, please reach out and we’ll be happy to help.