Chrome logging me off the app and Firefox still buggy


#1

Does anyone know how to keep the GF login window from popping up in Chrome? Hopefully it’s just something minor I forgot to do like check a box or something…
(Or better yet, can we get Firefox stable again :frowning: )

So I had quit using Firefox becasue it still keeps randomly doing this. I opened Firefox again today becasue Chrome was giving me issues. Firefox worked fine for a while and then material disappeared from view. When I moved the artwork over a few inches on the GUI, everything disappeared from view.

So I went back to Chrome and it’s still randomly asks me to log in. I don’t know if anything in particular triggers it or if it’s just random, but it occurs after being on the GUI for hours without issues. Today it happened when I was moving the artwork around. I doesn’t appear to actually log me out of the GUI as I can click off of the popup window and it goes away, but it refreshes the desktop and all the changes I had made since uploading the artwork disappears. (I’ve lost three projects becasue of it.)

The prior two times it happened was when I ran the first part of a project successfully. After the initial print I wanted to repeat a cut step. When I went to process it, the login window popped up. I closed the window and it again reverted to the original upload and I lost all my alignment.


Authentication dialog
#2

Non-authoritatively breaking down the issues…

Chrome-- you should make sure the “remember me” box is checked, and that it’s set to allow and cookies. There are settings that can clear cookies after each session, too. I use chrome 100% and have never seen this behavior, sorry to hear you’re having problems with it.

Firefox-- by any chance have you set a zoom level in the browser itself (as opposed to the GFUI)? That’s been known to banish images from the window.

Both are longshots, but hopefully helpful. :v:


#3

Does Safari work yet? That is my preferred browser.


#4

It’s my preferred browser too. And it mostly works. It used to have several bugs but the only one I’ve run into lately is that it still sometimes has problems with positioning and zooming.

It’s good enough that I occasionally use it for quick things but if doing a serious project I still use Chrome because it still works best for the Glowforge.


#5

Thanks for the update!


#6

I’ve always wondered this when questions like this come up, so take this with a grain of salt… but are you running Chrome with any Cookie or Ad Blockers enabled? If you’ve asked Chrome to store your account credentials and are still getting asked, it could be that browser cookies for the session are disappearing.


#7

About the only time I see this or similar behavior is when I have the GFUI open on two different computers. I’ve only got the one about configured and it is generally as simple as closing one of the sessions. If the problem persists after closing the second computer’s session a browser refresh generally will fix the problem

I run Chrome on a Windows 10 machine and use Chrome on a Chromebox at the GF for starting jobs


#8

I honestly don’t know as I downloaded Chrome specifically to use with the GF and don’t use it for anything else. So whatever the default setting are is what I’m using. I guess I’ll have to figure out what they are. Thanks Dan, hopefully it’s something this simple :slight_smile:


#9

OK, I’ve been on the GUI for a few hours and the window randomly popped up again. I have noticed the last three times or so it’s happened when I start to process a project.

I don’t think this is it as I only have it open on one computer and the GUI is only opened in one browser. Refreshing works to clear it, but it also destroys all the settings and alignments. :-/

Thanks dwardio. Yes, I have it set to remember me. I don’t ever have to log in at the beginning of a session and the log-in never occurs in Firefox, just Chrome. I’m guessing it has to be some configuration I’m missing in Chrome, but hell if I know what it is lol.

I’m sorry, I’m not sure what you mean by “set a zoom level in the browser”? I’ve had the images disappear when I’m zooming in Firefox so I’m guessing it’s the same bug that’s happening in Safari, but the last few times it disappeared when I was just moving the artwork around. The irritating thing is this is a new behavior for my Firefox and it was working great up until very recently.


#10

Is your internet connection completely stable? My router will disconnect briefly once most days. Some stupid system BT have to adjust line rate. Some web apps don’t like it. For example in Blogger it won’t save a post being edited. I have to copy all the HTML, re-edit the post and paste it back again before I can save it.

If the GFUI doesn’t like a re-connection and loses work that will be very annoying as I can’t have a constant broadband connection with my current ISP.


#11

Nor I. And I often have multiple machines, tablets or phones logged in too (I don’t log out unless I hit a problem with a print so I"m usually just reusing a session that may be days old). I’ve got decent wifi but not great - I’m in the basement about 50 feet from my wireless router which is upstairs and on the other end of the house.

Are you running any other 2.4Ghz device nearby - like an old microwave?


#12

Tritto.
©2017 @Jules


#13

It’s possible it’s has a momentary disconnect, but I never noticed it being an issue. Would the connection issue be dependent of the browser though? I’ve never gotten this pop-up on Firefox, only in Chrome.

No, one in the next room though (Microwave).


#14

I don’t think so. It depends on the website. Some websites don’t like a reconnection. I would expect banking sites to require new login but you don’t lose anything when you get logged out. With GF you lose everything and potential waste material. There seem to be so many ways to waste material with a Glowforge’s unreliability.


#15

Perhaps we should figure out what the actual problem is rather than just saying something is unreliable? Pretty sure this is the first mention of such this problem in #problems-and-support so it’s not even known if this is a “Glowforge” problem or perhaps something with the local settings.


#16

The unreliability is not just referring to this problem. I see lots of cases where people lose their current job settings. Bad enough that we can’t save them but they seem very ephemeral, like they are saved in a session cookie or something that gets wiped at the drop of a hat, or internet connection.

Glowforge decided to use WIFI and not give an Ethernet port and use a cloud connection. These things are not robust and the software often crashes. The end result is people lose all their settings and if it is part way though a job often waste material.

Contrast that with all my other CNC machines. They are all hard wired Ethernet, don’t need an internet connection, all save their jobs on my server, so I never lose anything or waste material unless there is a power cut in the middle of a 3D print.


#17

Stop being rational. I’ll get some torches. You can get the pitchforks.

:slight_smile:


#18

And it very well be just me having some setting wrong in Chrome. It’s the first time I’ve ever opened it so it’s likely some cookie thing or something,


#19

Hi, @kittski. Thank you for these details. We’re looking into it. In the meantime, please make sure you’ve logged out of the Glowforge app on all browsers except the one you want to use.


#20

Will do. For now I just gave up using it and have gone back to Firefox. When I have a smaller project where the logging off doesn’t matter, I’ll try Chrome again and I’ll be sure to log off Firefox. FWIW, it does seem directly connected to “preparing the project” as the last three times it has happened I was on the Chrome GUI for a long time with no issue. When I went to process the project, it gave the log-in popup.