Click on a file on the home page and it does not show as an image to use

Newbie here… I created a fox image to etch on leather. Worked very nicely on our test piece of leather. Now we cut the a piece of leather and was going to etch it and it will not load. Any ideas why fox good

I think your image is just too complex – bazillions of nodes. Since you’re engraving it anyway, you should just rasterize it and save it as a PNG to bring into the GFUI.


Oh… ok … I thought it had to be a .svg to bring it in. I will try that. Thanks!

1 Like

SVG is just a container file. It can contain vectors or rasters. :slight_smile:

I’m sorry you had trouble uploading your design.

@geek2nurse is right, with a file that complex you will need to either reduce the number of nodes or rasterize it. If you want to cut a file it will need to be an SVG or PDF. JPG and PNG files can only be used to engrave. The SVG or PDF file needs to contain lines called “strokes”, which are turned into cuts.

Were you able to print your file by rasterizing it? If not, let me know and we can look into this further.


There’s nothing wrong with the vector image you uploaded. It only has 7407 nodes - it processes (“calculating precision movements”) in about 30 seconds and prints just fine (I just tried it on a piece of scrap).

I have designs with over three times as many nodes that also print just fine.

Hard to understand from your description and post, but it sounds like you deleted the file after your test. Just delete the blank design, upload it again and engrave it.

Either way - it’s not a problem with the UI or your machine.

1 Like

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email