Cloud_auth_rejected error message offline in app

Hello all,

I was using my pro with great success since installed (less than a week). I came in last night (Friday Jan 3) and it was stating it was offline. (GF was off and PC was sleeping Thurs night after use) When I power it on it lights up and the fan revs for a few seconds then lowers to idle. Nothing mechanical moves other than the fan. I’ve tried all the troubleshooting I can find in the forum including a factory reset. I have pulled the logs along with some network troubleshooting and have discovered the following,…its getting an IP address and I can ping it locally in my network so I know its connecting and can send/receive data ( I have confirmed this also with a local DNS server that is communicating with the GF).

Here is what I get from the logs after a factory reset (to clear them) and retrying the setup process…

2020-01-04_19:01:56.29993 udhcpc (v1.23.1) started
2020-01-04_19:01:56.34970 Sending discover…
2020-01-04_19:01:58.51522 Sending discover…
2020-01-04_19:01:58.59000 Sending select for…
2020-01-04_19:01:58.67013 Lease of obtained, lease time 268435455
2020-01-04_19:01:58.71476 /etc/udhcpc.d/50default: Adding DNS
2020-01-04_19:01:58.71478 /etc/udhcpc.d/50default: Adding DNS
2020-01-04_19:01:59.23486 ERROR:root:401 Client Error: Unauthorized
2020-01-04_19:01:59.26484 ERROR:root:{‘ssid’: ‘MYWifi’, ‘bssid’: ‘ac:84:c6:c0:22:cb’, ‘wpa_state’: ‘COMPLETED’, ‘error’: ‘cloud_auth_rejected’, ‘mode’: ‘station’, ‘details’: “HTTPError(‘401 Client Error: Unauthorized’,)”, ‘pairwise_cipher’: ‘CCMP’, ‘group_cipher’: ‘CCMP’, ‘address’: ‘28:ec:9a:98:cd:08’, ‘in_recovery_mode’: False, ‘freq’: ‘2462’, ‘key_mgmt’: ‘WPA2-PSK’, ‘ip_address’: ‘’, ‘id’: ‘0’, ‘serial’: ‘XXXXX’, ‘uuid’: ‘XXXXXX’} —>(removed)
2020-01-04_19:01:59.26883 - - [04/Jan/2020 19:01:59] “POST /setup/connect_and_check HTTP/1.1” 504 444
2020-01-04_19:01:59.34491 - - [04/Jan/2020 19:01:59] “POST /setup/connect HTTP/1.1” 410 0
2020-01-04_19:01:59.50620 - - [04/Jan/2020 19:01:59] “GET /logs/zip HTTP/1.1” 200 14658

After it connects (and the teal light goes out as expected), all the logs show that when the GF is trying to connect to google its unauthorized in some form or fashion

2020-01-04_06:35:29.58600 ERROR:root:401 Client Error: Unauthorized
2020-01-04_05:11:07.61335 ERROR:root:Failed to upload event (firmware_update:check:starting): 401 Client Error: Unauthorized
2020-01-04_21:31:18.35908 3690 INFO: net: requesting socket token
2020-01-04_21:31:18.77812 4112 ERROR: socket token request: http_code=401, result=22 (HTTP response code said error), details=“The requested URL returned error: 401 Unauthorized”
2020-01-04_21:31:18.79193 4116 WARNING: net: failed to receive token
2020-01-04_21:31:18.79198 4116 INFO: net: retry delay milliseconds: 2000 * 2.0 ^ 0 + 665 = 2665

I have emailed support but waiting on a response…Any ideas would be appreciated!!
I don’t think I or we can resolve this but maybe it will help someone else…


Hmm looks like your GF is requesting an IP from your router, and gets it successfully, then adds the google public DNS servers and then gets a cloud authentication error. All those “unauthorized” errors probably are happening inside the cloud foundation on google side (I’m guessing GF company uses google cloud hosting for their environment).

The authentication errors point towards a handshake issue between your GF, and whatever authentication app runs on the google hosting side.

Just a guess, but I’m pretty hopeful that the GF team will be able to help resolve what is looking like a hardware (your GF) / platform authentication error.

Good luck, interested to see what the fix ends up being :slight_smile:

Oh one more thing, you mentioned reaching out via email as well. Both the email system and opening up a post here serve the same purpose, and having both opened can slow down their response time.


Thanks for the input!
I’m sure its something software on either GF or Google’s end the machine seems fine otherwise…
The bad part is, I’ve lost the whole day not being able to use it. I have a long list of projects to complete and was off work today. Going back tomorrow…ha ha oh well, such is life!! :crazy_face:

I got mine for my wife for her Christmas present this year. Worked for 3 prints then something broke and now going through repairs / support. Think a day is bad? Try not being able to play with your one present, having a house full of crafting women over all looking at a huge piece of shiny plastic they could only look at pictures of its abilities online googling lol. Man it sucked. Hopefully the one I get next week works :slight_smile:


Oh no…so sorry to hear! :fearful: It was our present also. My wife showed it to me and knew we had to get one sometime. Next thing I know she’s ordering one. So Merry Christmas. Though I’ve definitely spent more time with it than her so far…lol I wont complain too much, there have been some folks who have similar experiences to yours…such a bummer…especially with such a hefty price. I hope they get you squared away and you can get and up running soon :grin:. It took about a month to receive ours. It arrived just before Christmas. I just finally got it setup and the vent installed to be able to use it. I was doing some small items just get the hang of it. Used a sheet and and half of the draft board and a few pieces of hardwood and poof…offline since Thursday night…let me know when you get running. Hopefully it will be soon :wink:

1 Like

When the Glowforge was not operational but the computer was, I focused my time into first learning Inkscape and then designing Glowforge ready work for when it was operational. I waited 6 mo for it to arrive and then a bit over a month for repair but that was easier than most at that time and the most recent machines have many things tweaked from learning from those first machines.

I taught myself Inkscape in that first 6 months and made many designs in the month it was gone. I have found that Glowforge time is only a minor part of the time spent designing and finishing.

1 Like

Hi @MarcJPo,

I’ve reached out to you directly over email to address this issue. Since we’re communicating there, I’m going to close this thread.