"Compact filter attached" setting is missing

I’d like to try out some external evacuation solutions, and keep hearing about this “Compact filter attached” setting. My UI appears to be missing this option, which hinders my experimentation. Is this something that needs to be enabled from GFHQ? If so, please do. Thanks!

It’s under the Settings (gear) icon.


1 Like

May we safely assume that you have a compact filter? :slightly_smiling_face:

1 Like

Okay, it’s supposed to be under the Settings icon. :rofl:
(Support will have to turn it on for you.)


You can safely assume that I’d like the option to be available to me, as it is for others. :smile:


You get it when you get a Compact Filter. If you have the filter but no setting, then Support will need to enable it for you but it’s a quick fix remotely over the cloud.

1 Like

interesting that it’s enabled for some who don’t have the filter and not others. i don’t have the filter, but it’s available to switch for me.


I think it initially rolled out manually so there’s not complete consistency. But they just push it to folks who need it and raise their hand.

1 Like



Well, call me confused. I understand that you would like the same option as others have, but if you have no compact filter to begin with, what good will having the switch do and how can you possible experiment with venting/evacuation options? If you DO have or are planning to buy a CF, you can have the switch enabled

1 Like

There are other venting and exhaust solutions, the details and benefits of which can be found and discussed elsewhere. Some are good, some are pointless, some are pretty stupid. I’m not suggesting that anyone “go rogue,” I have simply chosen to try out a few ideas for myself.

To try these solutions, it’s necessary to switch off the internal exhaust fan. The CF toggle is the easiest way to do this.


OK…that makes sense to me now. Thanks

I have the setting but no filter - so I thought they enabled it for everyone
(hmm, I had a filter on order so maybe that’s the difference)

but yeah, support should be able to fix it either way :slight_smile:

I never ordered a filter, but have the setting.

(I also no longer have an internal exhaust fan, but have that setting checked just in case some day they decide to see who’s hacked/removed the fan…)

1 Like

Thank you so much for the details and posting that screenshot. We are looking into this now. As soon as I have more information I’ll update this thread.

I have it and never ordered a compact filter.

I also have the setting but no CF ordered

Thank you for your patience.

When using the Glowforge App in your browser, do you happen to have an Ad-Blocker extension installed?

If you do, and then disable this Ad Blocker, does the toggle for the Compact Filter continue to be greyed out?

1 Like

Huh. I just opened the app on my phone from work, the setting does appear. You may be on to something. I’ll check various browsers/extensions when I get home and report back.

Thanks for the lead!

1 Like