Compact filter not working

#1

My compact filter has quit working. Smoke just lays in the GF rather than being evacuated and it starts leaking out the front of the GF. I turned up the dial. Still no smoke removal. Thinking it might be a GF fan, I hooked up the vent to the outside. Everything worked perfectly. The filter has been in use only since the second week in March. I am not an intensive user. I have not used draft board or similar products. I have mostly used proof grade materials. Surely the filter should last longer than this. What do I do now?

1 Like
#2

I would check the exhaust fan grill for clogging. That will cause the intake fans to pressurize the interior and force smoke out of the lid and door edges of the machine.

2 Likes
#3

Thanks for your suggestion. But all smoke is evacuated when I don’t use the compact filter (vent to outside). Wouldn’t that indicate that the GF vents (including the grill) and fans are working?

1 Like
#4

Yes, I think so.

#5

Silly question, but did you check to make sure the filter option hasn’t gotten turned off in settings?

#6

The filter option was turned on until I vented to the outside. Your question is not as silly as my husband’s first question, “was the filter plugged in.” That one was silly because you can hear the filter throughout the house. No question that it was plugged in.

1 Like
#7

Oh no! what you’re experiencing sounds like a full filter cartridge. I’ve followed up with you by email.

closed #8