Compound Path Issues when opening in GFUI (even after reading other threads)

Hi everyone, I feel like I’ve tried everything and there’s always an issue. [Photos below]

Problem: I want to import a vector file into GFUI but during import it screws up all the compound path lines and the image is terrible. I was able to fix it, but now when I combine different vector images into a new file, and only change the fill color, it goes back to not working.

The image I imported to the GFUI was fine, but when I copied that vector image into a different illustrator file, and then the same with 3 other separate vector images, all the problems came back and they looked the same as before. When I pasted them into the new Illustrator file the only thing I changed was the fill color so I could use different settings.

I’m at a loss and any help would be tremendous.

This is the original full size vector image

This is the above file exported as .Svg and imported into GFUI looking good

The bottom BG’s are the good rendition sized down. The ones above were compromised. Hard to tell with zoom so see last picture for better idea of damage

If you would zip the file and drop it here we could look it over for issues.

Doing that right now. I came across something while doing so, after I pasted the good vectors after making sure the compound path’s were right I realized I also scaled it down to about 10% the original.

Would scaling post treating compound paths for engraving undo the original treatment?


  1. Logo as ai
  2. Logo as .svg
  3. .svg used after scaling down - does not translate into GFUI
  4. .svg after confirming vectors were good, pasting into new file* and exporting all together - Successful import to GFUI

*I take back what I said about the images looking bad once pasted into new file. Apparently it only happens when I pasted & scaled down before exporting to .svg (191.8 KB) (191.8 KB)

1 Like

I tried opening this file but I’m not understanding what’s wrong with it? Could you describe or point out some detail to look for to understand the problem?

lol exactly, try this

  1. Take zippp.svg and open in GFUI, should look fine and take up a lot of the artboard.
  2. Take ^ same .svg file and open in illustrator and scale it down to about 15% size / 50mm diameter
    while leaving artboard as is. Save and then open it in the GFUI.

If you get what I got, the rendition in GFUI after the above steps essentially undoes all the compound path work done to make the original file open full scale.

Did I explain that well? This whole process has my brain turned into mush.

Thank you for the detailed steps. I have a guess what the problem is. When you save your SVG, what do you have “Decimal Places” set to? It looks like it is 1 in your file. I think you’ll find you get better results if you set that to 4.

What’s happening is it’s rounding all the coordinates to one decimal digit, so for example a point that should be at 4.8426 gets rounded to 4.8. This makes more of a difference on smaller things, especially if you then scale them back up.

This is what I use, for the least amount of hassle:


Pretty certain Chris is on the right path.

I opened the logo SVG, made two copies, getting smaller, then saved. I opened that file in the UI and scaled it up, the smallest one has just as much detail as the largest. I use Inkscape, which appears to work down to 6 decimal places by default.

I’m sorry you ran into trouble with your design in the Glowforge App. The SVG settings which @chris1 shared, including the advice about decimal places, would be a great next step to try. Thanks Chris!

Did the recommended SVG settings solve the issue?

Awesome, going to try and see how this helps. My CSS was set to ‘Style Elements’ and Decimal to ‘1’.

Appreciate you looking into it. I was thinking it was an illustrator thing, but I’ll see with the new settings.

I haven’t tried them yet, next print will have the updated settings.

BUT… today I noticed a bunch of updates within the GFUI which pretty much allows us to import any size vector and then punch in scale and positions which is PERFECT. 10/10 should have been a feature way long ago. It also seems to run smoother when clicking between things.

Thank you for the feedback regarding the updates to the Glowforge App! I’m just checking in to see how your most recent prints went. Did using the suggested settings work out well?

It’s been while since we’ve heard from you, so I’m going to close this thread.

Please start a new thread or reach out to if you run into any more trouble.