Connects, but won't STAY connected to WI-FI

Today is the first day we’ve run into this issue. When powering the GF on, it says offline and won’t go through the centering, focusing etc until I run setup again and get it to connect but I know I am not supposed to be having to do that every time…becoming a pain real quick.

1 Like

I have seen the following steps work well in some cases of this behavior. It is worth a try. This is for the most common internet connection types:

  1. Unplug the power from all the network devices. This is everything from your modem to your router and WiFi unit. You may have more or fewer devices than this depending on your setup.
  2. Turn off your Glowforge.
  3. Turn off your PC.
  4. Start your modem. This is the unit where the wire comes from the wall to give you internet access. Wait for the modem to boot completely.
  5. Start your router/WiFi unit. Wait for it to boot completely.
  6. Start any other network devices in the same manner.
  7. Start your PC.
  8. Turn on the GF.

If the GF doesn’t connect, run the connection process again. If the problem persists, please update.


Have you tried turning off your computer, Glowforge and router. Wait about 10 minutes. Turn your router back on and let it fully boot. Turn your computer on and let it boot. Turn on your Glowforge. Open the Glowforge app. This has worked for some wifi issues.

Never mind. While tapping this out @ben1 gave better instructions.


Thank you for the detailed steps. Trying this now…will update in a bit.

That didn’t seem to work…when you say “run the connection process again”, do you mean the process or that whole process of unplugging & restarting everything?

The process.

Yes, I did that and of course it reconnected again…as it did earlier. I haven’t shut it (the GF) off again yet though to see if it automatically reconnects like it’s supposed to. I thought I’d go ahead and get a practice cut while it’s on, so I’ll check about that later.

Since it looks like the GF has connected and been stable in the past, I would look at your WiFi equipment as a possible failure point. It may be that the GF isn’t able to maintain a constant connection because your WiFi equipment is failing. If you have a data plan on your cell phone and can set up a WiFi access point using the cell phone data you can eliminate the house WiFi as the problem.

It is also possible that the GF is the issue. If that is the case you will need to wait for support.

It’s still not automatically connecting or running the startup process. I’m through with it tonight and will resume trying to find the issue/solution tomorrow. :frowning:

Try using your phone as a hotspot, to eliminate your existing wifi as the problem.

Are you on a dedicated 2.4gHz network? If trying network “band steering” (Xfinity has been pushing that–in theory the device will select what it needs) or a 5gHz system, the GF won’t function properly…

Thanks so much for the help in this thread, everyone! @ben1 already provided a great deal of the first steps I would suggest, so thanks for trying those already. Based on the details I found in the investigation of your Glowforge logs, it does look like your unit is having trouble keeping a consistent connection to our servers. However, because network-specific Wi-Fi challenges may occur for a number of different reasons, there are a lot of factors that need to be considered so we can narrow down the problem. I have a few suggestions that may help:

  • If your Wi-Fi network includes several access points, it’s possible that your Glowforge needs to re-establish its connection whenever it ‘hops’ from one access point to another. As a test, you could try creating a dedicated access point for the Glowforge to see if that helps.
  • Since Glowforge only uses the 2.4GHz frequency, a connection will be harder to establish and maintain on a crowded 2.4GHz network. Other devices using 2.4GHz, like cordless phones and microwaves, can cause interference and an unstable connection. You can consult your router settings to check the performance and traffic on your 2.4GHz network.
  • In your network settings, check the channel you’re using for the 2.4GHz band. Trying a different channel may provide a more consistent connection.

If you’re still having trouble, there’s a test you can try that will help us narrow down the problem. @ben1 and @eflyguy already mentioned this, and it really is the best next step. If possible, could you please create a Wi-Fi hotspot with a cell phone and use that network to connect your Glowforge to Wi-Fi? This is a good way to rule out signal interference, since you can set your phone right on top of your Glowforge.

You can find instructions online to help you create a Wi-Fi hotspot using a cell phone. Make sure that you set it up to be a 2.4 GHz hotspot, since that is the frequency your Glowforge uses.

Once the Wi-Fi hotspot is broadcasting, you can connect to it by following these steps:

  1. Turn on your Glowforge.
  2. Wait 30 seconds. Then hold down the button for ten seconds until it glows teal.
  3. Navigate to and follow the instructions on-screen. When prompted to connect your Glowforge to Wi-Fi, choose the hotspot you created.
  4. Once Wi-Fi setup is complete, go to and try a few prints.

Let us know how it goes!

We have been running into this same issue the past two days on all three Glowforge units at our school district (all on the same network but in different buildings/locations). They require us to go through setup each time we turn them on, and then they work fine. If they are turned off and then back on, we have to go through setup again. Has something changed? I noticed that if I enter an exception for its IP address in our Web filter (to bypass the filter) it will work, but I can not give the Glowforge a static address to make this the solution (our MAC to IP mapping is not controlled by us and it does not appear there is a place to enter a static IP on Glowforge). Our Web filter bypass will only work with an IP, not the MAC address.

Can you provide me with a list of address that Glowforge needs to connect to (that we need to unblock)? I have monitored the connection and unblocked everything listed in our logs…but it is still not working unless we reconnect each time. Maybe if you supply a list of domains I can make sure our filter is set to allow those.


-Russ Cole

You should likely open your own topic for the issue to keep from getting the support personnel confused. This will allow them to communicate specifically with you on your problems.

1 Like

I found this thread and posted here because my symptoms are identical to @amykaway. It looks like this issue may be more widespread in certain situations/networks.

I realize that, but Support has asked other users who have done as you have to please open their own support ticket.

The thing is that opening a topic here in P&S creates a support ticket, and there can only be one customer per support ticket. :slight_smile:

I emailed this in to support to generate my own ticket…just wanted to add to this thread as well.

1 Like

We only had a little time to try this morning with it, but still didn’t get it connecting on it’s own.
We’re kind of newbs to wifi hot spotting, so how do we figure out what our hot spot password is? We started to run try running that way but ran out of time while trying to figure that out. We’ll have a bit more time to dedicate to it again tomorrow.

You set your Hotspot password when you set up the hotspot. You may need to look up instructions for your specific phone.