Dashboard items not loading into GF

Several times now, I have had artwork available on the dashboard, but when I hit the “open” button and go to the GF view, there is nothing there, and nothing is showing in the left hand column under “art work.” The work around has been to “Add Artwork” and reload the image off the hard drive. Annoying, but not a real issue. Tonight I tried to burn some earrings that I bought off the Catalog, and I get the same issue. They won’t transfer to the GF. They show up on the dashboard just fine, but won’t open despite repeated PC reboots and GF restarts. Since these are purchased items, they are not on my hard drive for the workaround. I need to find out what the actual issue is and get it fixed. Can anyone help?

Any changes you make to a design, including deleting portions you don’t want to print right then, are saved to your dashboard. For the catalog designs, you can reset them (click on the 3 dots in the upper right), but for designs you upload, anything you’ve deleted will stay deleted and you’ll need to re-upload it.



Yes. But the problem is that NOTHING shows up. I haven’t made any changes, just nothing shows up.

Even after you do a reset?

Try a ctrl-A (select all) and zoom out to see if maybe the design got moved off the workspace?

Wait, no, if there’s nothing on the left, there’s nothing there. That’s odd. :frowning:

I’ve been dealing with it for 2 years, and after a couple complaints & not getting any real assistance, just gave up. But really once I had more than 2 pages full of designs in the Home dashboard, it was always faster for me to upload and find the design in my own computer files anyway, so I rarely even look at the dashboard. (I’ve also had where I’ve tried to open one file, and an entirely different image loads. Sigh).

I have a folder for “Images for Glowforge” and then about 30 folders under that for type of image & shapes/templates and then lots of subfolders within those. This works well for me as I can get to exactly what I want with only a couple clicks versus lots and lots of scrolling in the dashboard… And it works every time! (when you don’t have an issue with the file type or content, that is).

I’ve had this failure since nearly day 1 (2 years ago). Or sometimes a different image loads from the one I selected to open. Complained about it a couple times, too, but no change. But I just upload as it’s faster for me to find my images within my file structure than scrolling thru the dashboard…

1 Like

Just checking - are you deleting the file within the app after you print it?

1 Like

No. I just go back to the dashboard to do the next thing.

No. Just going back to the dashboard for the next project.

I think you’ll need for staff to see if they can help you. :frowning:

@geek2nurse is correct. You may not see a design (and see a “No Artwork” message) if the original design’s artwork was deleted while preparing a print. When you edit a design on your Workspace, the changes are automatically saved as you make them. That means that if you close your browser, navigate to another page, or just hit refresh, your work will pick up right where you left off.

Should you make a change by mistake, you can use undo any time until you leave or refresh the page. If you want a clean start, you can always go to your dashboard and click the upload button to upload the file again. If you got the design from the catalog, then you can start fresh by opening the design, clicking on the three-dot icon, and choosing “Reset Design” to remove all changes.

Please note that the thumbnail in your design library will only reflect the design’s appearance when you first uploaded it, and will not update as changes are made.

If you’re still running into trouble, could you please send us a screenshot of what you see in the Glowforge app when this happens? Make sure to include the rulers in your screenshot and show as much of the bed as possible

To take a screenshot:

Mac: Press Shift-Command-4 and click and drag a box around your image. You’ll find the screenshot file saved on your desktop.
Windows: Click on the Start Menu and type “snipping tool”. Open the Snipping Tool > New then click and drag a box around your image. Click the Save icon and name and save your file.

Once we have the screenshot, we’ll be happy to take a look.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.