Dashboard super slow to load

Hi,

It’s been a few months since I used my Glowforge. I went to app.glowforge.com and didn’t see any of my previous designs. Tried to upload a new design and then it just stalled out. I cleared my cookies, etc - same deal. Then I tried a different computer, same deal. THEN, I went and did something else and eventually my designs loaded. After diagnosing, it seems after hitting reload or loading the dashboard for the first time, it takes 60+ seconds for the UI to become interactive. Once active, everything seems fine. I’m getting 75+ Mbps on speed tests on both machines.
This is happening last night and tonight.

Any thoughts?

possible browser extensions like anti-malware, ad blockers, etc? Might want to try a different browser you don’t normally use that doesn’t have any extensions installed.

4 Likes

When this happens to me, I clear my cache and reopen the app. If it still feels laggy I use a different browser. One or the other fixes it for me.

3 Likes

Hi Blaine,

My name is Mercedes and I’m part of the Technical team here at Glowforge and I’ll be helping you troubleshoot today. I’m sorry you are having trouble with the Dashboard loading!

Thanks for letting us know. We need a bit more information to investigate. Please do the following:

  1. Go to https://www.whatismybrowser.com/
  2. Look for the header that says "Your web browser’s unique URL"
  3. Click the button that says "Copy URL to Clipboard"
  4. Reply to this, and paste in the link provided

This will help us understand the circumstances around the error so we can work on it for you.

Are you still having trouble with it taking this long now?

Regards,