Dashboard to Rendering - Page is not responsive

Is it just me, or is anyone else having difficulties getting files to render? This has been going on for over a month now. And yes, I’m paying for premium service, I’m just not getting it. Already been through reboot, hard boot, restart, reload, etc. I have been trying for over an hour today to get a file rendered, but the page is still stuck on rendering. I’ve tried it on two different laptops and three different browsers. Glow Forge is the ONLY site I’m having problems with.

Will other files render - like the Gift of Good Measure? Whenever I have trouble loading a file, it is almost always the file.

1 Like

Rendering has nothing to do with premium, it’s only “preparing print” and “calculating precision movements” that are any different.

… and, no, no issue “rendering” here. I just uploaded a huge file (3MB) for printing, took just a few seconds.

Perhaps you could share the file if it’s not proprietary, and someone else could check to see how it works for them? Might be an error/issue with the file itself?

1 Like

This is a simple four line text file. And it’s not the only one I’ve had difficulty with. I’m not doing anything with this file that I have not done with dozens of other files. But for the past month or so, I have had difficulty rendering quite a few files. It doesn’t matter what format either. SVG, PDF are both very problematic.


The file’s not proprietary except in the sense that it’s a business logo.

ADTR KeyTags Back.pdf (340.0 KB)

Rendered for me in under 10 seconds.

What browser are you using and is it up to date?

1 Like

I uploaded the original again and it finally worked, but still took nearly a full minute here. GF is converting the text into individual bits of artwork and I’m wondering if that could be part of the problem. This doesn’t happen with every text file. Both Google and MS Edge are up to date. Mozilla doesn’t run worth a flip for me so it’s last resort desperation when I use it.

I have excellent luck with Firefox as well as Chrome. I didn’t upload your file, simply dragged it onto the interface. As for how the artwork is interpreted, how was it created and in which program?

Took less than a second to upload, 3 seconds or so to “process”, and way less than a second to “render”.

It was created by simply typing a text box in adobe illustrator.


Well, as demonstrated by myself and others, the file is fine. Suggest you email support and link to this thread so they can look at it as well.

FYI Glowforge is currently experiencing app issues.

Thank you for your comments and suggestions. I have sent an email to support but I don’t expect a reply for a couple of days.


Thanks again. That’s probably got a lot to do with the issues I’m having if they’re having problems of their own, lol


Is it possible that you are also using different kinds of font formats?

otf ttf postscript

Maybe something there is making a difference? Just spit-balling.

It’s a possibility. I’ve been using different font formats for several years and never had an issue that I could specifically say was that problem. But never say never


There are a few bits of weirdness in part because Glowforge is still getting its legs, unlike other programs that have been around 20 years or more. Text in particular from another program needs to be broken down into parts so it is just vectors unless you are using the very new premium text widget that does allow editing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.