Design Engraving Glitches

I’m having the worst luck figuring out this problem I have with this particular design I’m working on!
Seems like when I’m engraving this “complex” design, after few passes the engraving starts to glitch as if the machine gets stuck on a particular part and it keeps engraving in an horizontal way!

I’ve tried multiple ways to send the svg file, exporting it twice and even separated the layers but there’s also no consistency to the glitching’s as if each time I do a trial run it glitches in different spots!

I’m literally at a loss and need help figuring this out!

Uploading: IMG_4097.jpg…

trial 3

This is the file I’m working on by the way.

Could this be a physical problem? The fan shroud or printhead may be hitting something like a hold down pin.


No hold down pin. Just cleaned out the fan a bit and checked all areas under the belt to see if anything stopping it and no luck there.
Could it be the design itself? Is it too complex?

With the power turned off, can you move the print head left and right, and forward and backward? See if you feel any resistance or any bumps or hitches. My guess is a mechanical problem. Good luck.


There are some strange things in the design. One is that there is that grey gradient. Glowforge can’t process vector gradient fills.

And there are some strange boxes showing up like a clip path or mask. But I can’t quite figure it out.

that might be just my laptop rendering it.

I’d say there is something going on. You might want to rasterize this and then engrave it.

The other possibility is to use the combine on the letters and that might make the complex path more manageable.


oh wow I can’t see these lines on Illustrator! What software is this if I may ask?
And the gradient is just for me to remember I’m engraving on the back of a “Silver Mirrored” acrylic and the gradient turns to a vector path once I upload it to the Glowforge app.

Thank you!


I think it is an artifact of the Inkscape render. There are quite a few nodes with the Hebrew letters and that might cause some strange jitters. I can’t find any broken nodes though. I wouldn’t rule out a mechanical glitch that keeps popping up. In the meanwhile have you tried a different design with a detailed vector engraving and that has come up ok? That would be a differential diagnosis.

1 Like

I don’t get those lines (nor can I find them) in Inkscape for Mac.

There are only a little over 9,200 nodes - that’s not all that complex. I have one design with 38,000 nodes that prints perfectly. There may be something else going on in the file, but it’s not node count.

Are the letters directly in-line with those on the other side ok? If so, it’s not a physical problem.

1 Like

I have done multiple trials, created a new file - expanded the text and exported to svg. I REexported again and changed settings. Triple checked all design elements and its literally mind boggles me what is happening. I’m concerned now that the glowforge capability’s are limited and there are flaws in the Cloud base software itself, more then I originally thought.

The only thing that actually worked in one of my trials was to completely create a new file with just the header, print that then create a new file for the remaining text and print that afterwards.
But that was my last resort as I’ll have to manually align each “Job” which is not ideal in the long run if I want to create more of these designs.

1 Like

ahhh never mind event that method didnt work :(((
Look what happened **will attach the file I used now

long words

Did you make the text a vector as well? Honestly outside of designing aspects you don’t need the 3d flair in inkscape because it won’t be putting that into the actual lasering. I’ll see if I can take a look shortly and see what I can come up with.

I would seriously doubt such a universal limit or everyone would have it. What I see is the machine changing where it thinks it is. If you have not found another mechanical cause I would recheck the gantry belt that may be episodically slipping particularly if it shows up at different places on different prints.

1 Like

There are some limitations, but this is not a technically complicated design. It should work as a normal vector even with this many nodes. There definitely is something wrong.

One has to isolate each variable. So for example, engrave another complicated SVG that is created with Inkscape but doesn’t use that particular Hebrew typeface. I don’t know what else to say, but I’ll give it a go and see if it is machine specific.

Ok. My guess then there is something mechanical. This was the first file you uploaded. Not retouched.

This has no issues.


I suggested it was mechanical, and now we have reason to believe there is a belt slipping, a wheel that is cracked, debris in a belt or something is bumping something.


I agree with above. That’s why I asked to see the “other” side - if it is on both sides, given the design, it was most likely mechanical. A slipping belt due to incorrect tension.

I will get something very similar at times when I try to convert a jpg to vector with the scan feature in CorelDraw. The software will get confused with the path along the nodes especially if there is an outline or drop shadow associated with the image.
BTW- It looks really cool, may I ask as to what it says?

1 Like

Thank you for trying it out! It seems like you’re right and I have mechanical problems (I purchased the glowforge pro not event 5 months ago!!!) .
I’ll run some tests and see which areas are at fault (someone mentioned belt slipping, wheel that is cracked / debris).
Do these things can be purchased new in case something is broken/ripped?


Thank you! This is what I feared honestly (machine is only 5 months old I’m not happy about this at all)… Is there a tutorial out here to guide me in checking the right areas?