Designs Keep Disappearing/Reverting to Older status

Today was probably the 6th or 7th time this has happened. I’ll do my work in the glowforge app; leave it for the night and when I come back in the morning the designs have reverted to an earlier instance of the designs. I do most of my work in illustrator and upload into the app, so it is mostly a loss of settings and needing to re-upload, but I don’t always notice right away and if I don’t notice I end up cutting things wrong again. This never used to happen, until a few months ago and now it keeps happening. I’ve seen the suggestions about going to the home page to make it save, and I’ve done that and it has not consistently worked for me. Any other suggestions?

1 Like

When I am working with a file that I will use again and I have the settings dialed in the way I like, I always exit back to the home screen and reopen. In my experiences, it seems that the only way to ensure the settings are retained is to do this.

I have tried that one and it has not worked consistently for me. I reuse almost all of my files.

I’m sorry that you’ve run into trouble with your designs loosing changes that you’ve made. Thanks for letting us know. We need a bit more information to investigate. Please do the following:

  1. Go to
  2. Look for the header that says “Your web browser’s unique URL”
  3. Click the button that says “Copy URL to Clipboard”
  4. Reply to this, and paste in the link provided

This will help us understand the circumstances around your error so we can work on it for you.

Thank you. Here is the browser info:

Your browser is almost 2 years out of date. v12 was released September 2018, 12.0.2 is just a minor security update released in December 2018. You might try updating it.


Thank you for the information. @Eflyguy is correct that your browser appears to be out of date. If you’re unable to update Safari, another thing I would suggest to try would be to use the most recent version of Google Chrome. Please let us know how it goes!

Thank you. I will try the update and see if it helps.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email