Do PNG elements corrupt the file? Adding a PNG layer in a PDF produces "No Artwork" message


#1

Anyone else experience this? As you can see in the photo below, I am making “shot flight paddles” that have our logo (Sparkle Donkey) as well as the restaurant logo on then, so I swap out the restaurant logo in my PDF file. But when I pull in a logo from a PNG file in Illustrator and save it (as a PDF file), the Glowforge interface says “No Artwork”.

If I save the file without the bottom “Ghost Bar” logo, the other logos print fine. But as soon as the 3rd logo is added (input from a PNG source), NONE of the logos work - it says “No Artwork”, even if I set the 3rd one to “Ignore”. I’m guessing it’s the PNG source, but I don’t know, could be something else.

None of the logos are off the print boundaries.
I’ve reset everything (turning off machine, resetting web page, etc), it’s not that type of issue.
I’ve tried rasterizing all logos in Illustrator, that doesn’t help.
The only thing that worked was to vectorize the 3rd logo (which is kind of a pain). Then it works.

Anyone else getting this and any other simpler ideas on how to solve?


#2

In the upper left corner, the material is currently “Unknown.” Your “No Artwork” message will go away when you select a material or set a thickness value for non-PG material.


#3

Nope, that’s not it, unfortunately. I forgot to mention that as one of the common issues I already checked. I use “Uncertified Material” and select the height. Again, it works fine when that last layer (the “Ghost Bar” logo in this example) is not included in the visible layers of this file.

Here you can see it working fine after I’ve turned the last layer into a vector (still says “Unknown” in the top left). It’s something about the PNG import into the file, even when rasterized.


#4

There might have been a recently introduced bug in the last update.

The team is aware of it and is looking into it.


#5

Thanks so much for letting us know about this. We’re seeing this, too, and we’re looking into it now.

In the meantime, if you run into this issue, you can choose “Add Artwork” and upload any other file. Doing so should make your original design appear “correct” again, at which point you can delete the other file you added and continue to prepare your print. I apologize for the inconvenience, and I’ll follow up in this thread as soon as I have more details.


#6

Thank you for your patience. We’ve made a change that should resolve the issue you reported when working with your designs in the Glowforge app. Could you please try again and let me know if you’re still experiencing any trouble?


#7

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.


#8