Does the Glowforge have a resettable fuse?

I’ve been happily using my Glowforge for several weeks now, but tonight I ran into a problem. The software gave me this error:

The button turned yellow/orange as well. I turned the Glowforge off/on again, but was surprised to find that it appeared to be completely dead. I tried different plugs, waiting a few minutes, etc., but there was simply no activity beyond an extremely faint click when it got power (not the switch).

I figured I’d try again later, so I left it for about an hour–and when I came back, it powered on again, apparently normal (I haven’t tried printing anything, but everything else appeared to be working normally).


  • Is there some kind of resettable fuse that I blew, which disabled the power supply until it had self-reset? Or something else along those lines?
  • Is there any way to find out what caused the problem? Printing seemed pretty much normal before that point, except for possibly a small power reduction (unconfirmed, and may have just needed some lens cleaning). The problem happened around 9:45 PST on 6/12.
1 Like

No. Some (pro) have a breaker but those you have to reset yourself. There are firmware systems that watch for overheating or other issues but they do not act like a breaker switch. If there has been a glitch in the memory for any reason, turning the machine off and then on will do a hard reset.

1 Like

Hmm. I only have the Plus model. A hard power-off for a few seconds to a few minutes was not sufficient to reset the machine (I tried both the switch and pulling the plug). It was only after roughly an hour that it turned on again.

I had not been driving the machine particularly hard, and it’s in a cool area, so overheating doesn’t seem plausible.

1 Like

I have not had that issue with my Glowforge, but I have seen times when something interfered with a switch (or a plug) giving bad or no contact. Intermittent errors are the hardest to track down, sometimes working and sometimes not. Then the thing you last changed may not be the issue.


I’m a software engineer, so I know very well how difficult intermittent errors are :slight_smile: .

That said, there is a big clue here and that is the error I got immediately before I tried power cycling the machine. I’d never seen that before, and while I suppose it’s possible they’re unrelated, that seems like a big coincidence. Knowing what the error actually was would be helpful I think.


Then you also know that even when a specific error is reported like “overheating” might not be correct even then. and be the sensor or connection to the sensor as we have often seen. There are many such specific indicators, but then there is “etcetera” where specificity is not helpful or not specifically tested for.


The Pro does NOT have a breaker.

It has a safety interlock which has no effect on power. It simply halts operation, just like opening the lid.

(edit - except, unlike opening the lid, the machine will immediately freeze, the head will not retract. You have to power-cycle to reboot it. If you power-on with the link removed, the machine will not function - but it still powers on.)


As I have never done anything with it I was not sure.


Good luck, hope you are back up and running soon!!

1 Like

It’s very common for power supplies to have resettable fuses, so while I don’t think there’s a detailed teardown available that would confirm it, it seems likely (and consistent with what you experienced as well as several other reports of “let it sit for a while and it worked again”).

Glowforge staff may be able to figure it out when they check your logs. Unfortunately, the design decisions of the interface have generally been not to give detailed information to us end users.

Yeah, there is.

There is no “resettable fuse”…

Oh. I didn’t realize. Do you mind sharing a link?

The now abandoned project you are fully aware of had detailed analysis of the gf guts.

It’s a bit of a pain to get at it now cause Scott let his forums expire and delete but certain maker forums and GitHub still has the repository.

1 Like

Not detailed enough to tell that the power supply has no PTC fuse. O O must have better information to be so certain.

@scott16 I’m so sorry to hear your Glowofrge had an orange button come on.

I extracted the logs from your Glowforge to investigate, and it looks like the orange button is appearing because the Glowforge is having trouble communicating with the printer head. There are two key connections I’d like you to check for me.

Could you please do the following?

  1. Turn off your Glowforge.
  2. Holding only the finished black surfaces, grasp the printer head as shown. Pull gently up and back to disengage the magnets and remove the head.
  3. There is a small tab in the center of the wire ribbon. Push down fully on the tab to release it, and gently pull the wire ribbon plug from the printer head.
  4. Take a clear photo of the gold pins inside the printer head where you just unplugged the wire ribbon. It should look like this.
  5. Pick up the printer head and wire ribbon. Make sure the tab on the wire ribbon is facing up. Slide the ribbon back into the head until it clicks.
  6. As shown, lower the printer head over the metal plate so that it rests next to the two round posts. Then push it gently away from you – you’ll feel a “click” as magnets pull the printer head until it sits snugly atop the metal plate.
  7. Pull the laser arm all the way forward.
  8. Reach over the laser arm, and to the left of the inside of the unit and you’ll see this circuit board:
  9. Take a photo of the circuit board. If the cable I’ve indicated above with the red arrow appears to be loose, please reconnect it and try printing again. This cable should ‘click’ back into place.
  10. Turn your Glowforge back on.
  11. Post the photos you took in step 4 and step 9.

Hi, David. Thank you for the response.

The printer seems to be working fine now, but it is good to know that the orange button can mean a head a communication error. I’ve had to clean the head a few times now and it’s possible that some dust got in the contacts when doing so. I also noticed that the bottom contacts were a little dirty, and I cleaned those as well.

Here is the first picture you requested; it looks pretty clean and undamaged to me:

However, it may be that during one of my cleanings some dust got in the connector, so I’ll probably use some compressed air to clean it out in the future.

I don’t have the second picture available but since the printer is working, and I never touched that end of the connector, it didn’t seem too important. I’ll let you know if I run into further issues.

1 Like

Hi @scott16 - Glad to hear you’re back up and running!

Compressed air works great on these areas to keep them nice and clear of debris. I’ll go ahead and close this ticket since everything looks all set!

1 Like