Dropped It, stuck on focusing

Well, I really did it yesterday while moving my Glowforge with the intent of making it accessable enough to use. Dropped the whole darn thing, luckily (?) taking the brunt of the impact on my foot with a secondary impact against a bedpost that seems to have resulted in mere cosmetic damage to the outer plastic shell in the front right corner. After cursing more than a little, I’ve gotten things set back up and I’m trying to find the next step toward fixing things. At this point, it seems like the lid camera is either not connected or not communicating, as the image on the GUI does not update from the last bed image from some months ago and the app continually sticks either on “centering” or “focusing” after boot until power saving kicks in. Also, the “refresh bed image” command remains greyed out the entire time, although I’m unsure if this is normally available before calibration completes.

After reviewing the boards for similar issues, I thought that it might be a secondary problem with the firmware trying to update since the machine had been unused for some time, but the problem remains consistent even after booting with the lid open for an hour to allow updates to finish. Moving the laser arm to the center or to the top left seems not to affect things; when in the “centering” cycle it does seem to hunt somewhat, but “focusing” produces no movement and it seems random as to which the machine gets stuck on.

Cleaning lenses, changing browsers and wifi channels did not fix things, and I’ve checked and reseated all 5 ribbon cable locations listed in several other replies re: this camera (example: My turn to get stuck on centering, ugh). At this point, I’ve gotten myself convinced that the likely candidate is a connection further in that passes the camera signal, but I’m hoping that someone here might be able to get me as far as confirming or denying that the camera is communicating, since I’m not really familiar with the sequence of events that actually occurs in the gui prior to the “centering/focusing” step.

Anyone have a suggestion as to a likely next step?

Thanks in advance!!
(Photo of impact site, just in case it happens to be a relevant spot for cable routing)

1 Like

Oh no! Haven’t got any suggestions that you haven’t tried, you probably need to hear from Support at this point, but that’s a heartbreaker. Good luck. Maybe they can do something on their end. :anguished:


if you have a pro, did you check the “magic staple” interlock on the back, by the power button? An impact could have knocked it loose. That would be a wonderfully easy fix.
(although I think that would throw an interlock error message)


Considering the torqing that the machine went through, even if the frame is not bent, so much throughout the machine has been jarred or pushed i woild expect that you would be very lucky not to have to send the machine back to the shop.
Support might identify specific places to look and you might fix them and that would be the first step to try.

I’m an annoyingly honest person, but my best recommendation is for you to edit the P&S post to make the circumstances less obvious. Makes any warranty discussions more satisfying.


Thanks for letting us know about this, and I’m so sorry about the damage to your Glowforge. Since there are a great deal of components involved in the calibration process, a unit may stall during the “Focusing” stage for a number of reasons. So thank you for taking the time to perform so much troubleshooting and let us know what you tried (for some additional background, “Focusing” directly refers to the step where the lens inside the printer head focuses. When the lens moves in the head during this step, it sounds like a “tick, tick” noise). I took a look at the logs from your Glowforge and based on the components affected, I’d like to discuss sending us your unit for assessment and repair. I be in touch shortly via email to sort out the details.