Engraving blurry / shifting

Today I started having issues with engraves being blurry/ghosting. Unless something really strange happened on the servers it appears the head is getting out of position while engraving.

First, let me say that I’m not one of the people who just got their machine and have that bad batch of v-wheels. Mine is from the first 30 day funding batch and has been working great for a couple years now. This is the first real issue I’ve had, and one I’m out of ideas how to solve. The engrave itself is something I’ve ran a bunch of times, and I’ve even tried slowing down the engrave since I’ve had issues with the beta speeds before. Same thing every time, and over multiple attempts it will actually shift the entire image to the left.

At first I thought it was just dirt on the v-wheels since I engrave a lot of wood and crud builds up. I took the carriage off, cleaned it and the rail they sit on, no improvement. The belt and the v-wheels all look fine, no chips, no cracks, no missing teeth or stretched areas I can see on the belt.

It’s not hitting anything, I don’t hear any strange noises, I don’t use magnets for holding (I know that has caused issues for some people). The only slightly weird things I’ve noticed are when moving the carriage it has a small resistance in one area of the wheel rotation, but I feel like that may just be normal for the motor (it only happens when the belt is attached)., and I noticed I can easily twist the cross beam and I don’t remember that, although I may just never have noticed. The v-wheels on the Y axis all seem fine as well, although I haven’t pulled it fully apart to know 100%.

I’m at a loss. I’m hoping for something to try, because it’s long out of warranty and I doubt it would be worth it to ship it in to be fixed.

Assuming those pics are both rotated 90º, I’m betting X-axis belt tension.

There is an article on that in the support troubleshooting pages.

1 Like

They are both rotated. The issue does seem to be x-axis related, I’m looking at the belt tension article now to see. I never changed the belt, so I didn’t think about the tension changing.

It loosens/stretches over time.

That shadowing is very typical of a belt tension issue.

It does seem to be something with the belt, but the belt isn’t loose. Moving the carriage very slowly by hand I found that there was a bit of a knocking noise every after it moved the same amount of distance. It looks like the belt was almost trying to pull itself off the motor gear. I adjusted the tension a few times until it seemed to not be doing that anymore. I think it actually ended up being looser than it was before, but tight enough not to be sagging.

I did an engrave and it came out good again, so definitely something related to the belt. FWIW I feel like I started noticing little issue shortly after they increased the rapid movement earlier this year, and it may have just been getting worse over time.

Thanks for the help.


It worked well for about 2 hours, then half way through an engrave it started blurring again. The shadowing seems to be completely in the x-axis, but one interesting part is it seems to be far worse on the left half of the image.

Here’s a bit more information. I adjusted the belt again, this time making it tighter. The repeated resistance -> moves easily -> resistance pattern goes away and it’s very even movement with it tighter, but the belt makes a constant, rubbing sort of noise noise. The belt doesn’t hit anything it, so my guess is it’s the sound of the teeth not quite lining up on the gear, and that the belt may just be at the point where it isn’t a perfect fit for the teeth anymore. I’ve probably ran the machine 500+ hours by now if not more, and while the belt doesn’t have any obvious breaks to it, it does look a bit worn.

Right now that’s my best guess. I was able to get 1hr of engraving done without issue, and I have a long engrave to try tomorrow and see if it start blurring again…


The belt may well need to be replaced. They are consumables.

1 Like

I am so sorry you’ve hit a snag. Could you check the tension of your belts for me?

When pressing lightly on one side of the belt, the other side should not move.

Like this:

(You should see an animated image above)

Additionally, can you clean everything listed in these instructions and send us a photo of each part you clean: https://glowforge.com/support/topic/cleaning-service-and-moving/cleaning#things-that-need-wiping.

Let me know if the belt is loose and attach a photo of each part you clean to your response and we’ll determine next steps.

I’ve cleaned everything including the carriage belt itself and the gear. Then I re-tensioned the belts after putting it all together again. It’s working fine for now. From what I can tell, it looks like the teeth on the belt are starting to wear, and it seems like some of it may have been sticking in the teeth of the motor gear. After cleaning the belts and gear I don’t notice the rubbing noise I was getting earlier when sliding the carriage. The repeating bump I felt when moving the carriage is also gone.

Excellent news! I’m going to close this post for now, should additional issues arise feel free to contact us at support@glowforge.com.

1 Like