ERROR Print Stopped- Unable to complete print

We are trying to engrave an acrylic sheet on our glowforge, however it’s giving us an error message that says ‘Print Stopped Unable to complete print’. We unplugged our glowforge for a few minutes, reset our computer logged out and logged back in and re uploaded the image. However it still gave us the same error. Would someone be able to help us out? We need to get this project done asap.


Does the button on the machine flash any colors when this happens?

If it’s a transient error I exit back to the dashboard, and then go back into the art - and I’m usually good to go.

If it happens every time with that art then there’s usually an issue with the art file itself.

Welcome to the forum. I doubt the problem is the acrylic. The problem is undoubtedly the file. Can you load other files like the Gift of Good Measure? If that file throws the same error, the issue is Glowforge. If not, there is probably something funky in the file.

Hello @mwlandco,

I see that you’ve also emailed us about this issue and I’ve just sent a response to you there. To avoid duplicate communication, I’m going to close this thread and will continue working with you over email.