ERROR uploading files

I’m having some issues with my GF app. I design and upload files from my office computer. Then I go home and print them utilizing my iPad.

I’ve tried uploading a few new ones this weekend that I put together and I get this Error message:

“An error occurred on your Glowforge. Please refresh your browser before printing. It may also help to turn your Glowforge off and then on again.”

The GF isn’t even on at home and neither is the iPad that will be running it.

I’ve closed out my browser here at my office, but keep getting the same error.


Perhaps a work around is the fastest solution. Email your files to yourself or save to something like Dropbox. When your Glowforge is online and you are on the device you intend to use, it will be easier to troubleshoot the problem. Some people have the best luck using Chrome, others are ok with other browsers. It could also have something to do with using the company internet. At any rate, more information would be necessary to help with this problem. What kinds of files won’t upload? Can you upload the same file from your iPad but not from your work computer? If so, it isn’t the file, and it isn’t the Glowforge interface, it is your work connection or computer that is the sticking point.

1 Like

I’ve tried Chrome, usually use Safari. I’ve had no problem uploading in this manner for months. I’m just uploading .svg’s. Company internet shouldn’t be the issue - I own the company and have no firewalls etc. in place. Tried emailing it to myself - can’t save it on the iPad to where it can then be uploaded that way.

I’ll try taking a computer home to set up on the home network to see if that works.

Here’s how you can use a file emailed to your iPad:

In iPad mail, click on the design (svg or pdf) attachment in the message. It should open up and show the design. Click on the Share icon and choose Save to Files. Save it to one of the existing folders for Pages, Numbers, etc. (if you like you can create a sub folder for your designs within that folder by clicking on the folder+ icon). Open up the Glowforge app on Safari or Chrome on your iPad, and click on Upload. Browse to where you saved the file and choose it.

The only time this didn’t work for me was when I had errors in the design file and it wouldn’t even show it in Mail.

1 Like

Yeah what they said - but also, do a full cache clear on your browser. Sometimes an error gets ~stuck~ and that’s the only I’ve found to clear it

1 Like

Cleared the cache on Safari, tried Chrome, tried a totally different computer. Went home and turned on and off the GF.

Still says that I have an error while uploading

I’m so sorry that you are having troubles uploading your file. Could you please send us the file you’re running into trouble with? We’ll be glad to take a closer look. If you’d prefer to share it privately, you can always send the file to

Thanks JeffG It’s actually any file that I’ve been trying to upload - I have 3 currently

I see you emailed us about this and we’re working on it there, so I’m going to close this topic.