Files stuck on "rendering your design" potential solution: don't copy and paste

I just started to experience the same issue detailed in these other posts (see below) with almost all of my files that I have previously uploaded. I can open but the file gets stuck on “Rendering your design…”. I have tried 3 different devices, different browsers, and clearing the cache and none seem to work. I see a lot of closed tickets but no resolution. However I found a workaround.

There’s a pattern to the existing files that get stuck rendering. They tend to be files that I have copy-pasted something inside (ex. I upload one coaster file and I copy/paste it 5 times, or an 8-piece job and copy-pasted it twice.) I tried uploading then re-opening some complex files with multiple engraves and dozens of cut-outs, and they seem to load/re-load just fine. GoGM also works fine and it has multiple engrave/cut/score steps (and I have not done anything to it but drag it around.) But trying to open any file I had copy-pasted an item somewhere will result in the stuck on rendering.

For now, my workaround is re-uploading the file and NOT copy/pasting anything within the design. You can delete an item and it will open again, but you cannot copy/paste anything inside. Hope that helps people and I hope that Glowforge fixes this really annoying bug ASAP.

edit: just tried some more experimenting. If you copy/paste something within a document, as long as you delete the clones before closing out the file, it will re-open.


Going to tag the other users who posted their stuck on rendering issue so they can try my workaround (re-upload the clean file and don’t copy/paste anything inside.)

@valdesstephanie98 @Oyeah024 @natemellen2004 @corhoads @brad650hill @tdcotoni

Almost a week with this problem with no fix! HELP US SUPPORT TEAM! It took them 2 days to respond to my email to basically just say, we hope to get it fixed soon. Ugh. I know I’m not alone here, but sh*t. Even designs I used yesterday are now stuck on rendering. Finally getting to participate in markets and can’t print or fill online orders that I’ve gotten. HELP!

I am stuck also. I also have orders to get done.

Try uploading the file again and do not copy/paste anything inside. It will re-open again. I don’t have issues with uploading new files, just opening old ones. I think the bug is caused by copying and pasting an object, then leaving the design and trying to re-open it.

1 Like

Let me know if my workaround works for you! Re-upload your file and don’t copy/paste anything inside of it.

Oh my god!! Literally NONE of my designs are working now.

Yeah the majority of my files I have uploaded 1 object and copy pasted it a few times. Those all broke. But everything I had uploaded and only dragged objects around inside still works.

I am also having problems with stuck-in rendering. I need to print multiple key chains and it won’t
even let me open the file??? Glowforge please help fix this bug. Other files do open but not the ones I need to use tonight.

Re-upload the file. Better yet, if you’re making multiple of the same item try this:

In illustrator/Inkscape copy paste the item as many times as you want
Save the file
Upload to glowforge
Use the file but never copy paste anything
It will re-open as long as you don’t leave copy pasted objects inside the design

1 Like

My file was created in the glowforge software- but now wont open? I don’t have a copy to upload?

Then you’re out of luck I think /:you haven’t downloaded the file before? Is it simple enough to remake on illustrator/Inkscape?

Thanks for letting us know about this. We were experiencing an app impairment at the time of your report that was likely causing this. I’m very sorry for the trouble. Could you please refresh your browser window and try again? Let me know if the issue still occurs for you.

Yes, the issue has stopped occurring for me, thanks for letting us know

That is great news! Thank you for letting us know.

Please don’t hesitate to reach out again should you need anything. We’re happy to help!