Files wont render, page won't load, page keeps crashing

We have been having all sorts of problems over the past 2 days.

the main Glowforge dashboard page loads fine. All of the links work, but when I try to load one of my files it never renders. Most of the files that we have been printing on for a good while suddenly won’t load. we are running into error “out of memory”

using a windows desktop and Chrome. (I tried, Firfox, Edge, and my android phone) we have done ALL of the standard trouble shooting and been on with chrome support for over an hour.

this is very frustrating as we have lost 2 days of production.

is anyone else having similar issues and is there a fix?

1 Like

have those files opened before?
if so maybe your browser cache can use a good cleaning
zap those! and see if you get any better results!

also try a different browser, see if you have the same issues!


1 Like

all of the files that I am trying up run have been used for many weeks with no issues.

I have tried Chrome, Firefox, Edge, heck I even tried it on my phone! I have cleared my Cache, deleted my cookies, made sure the browser was up to date. all with no luck.

1 Like

Welcome to the forum.
Your issue is very frustrating and you are not alone in having this problem recently. You have tried all the things (different browsers, different devices) and still no success, so I think Support is going to have to take a look specifically at your machine logs to see why you can’t get pages to load.

One last thing to try while you wait is to create a blank design and drag and drop a file from your computer on the interface.


if its possible to .zip one of the files and let us try it on our end, I have had zero issues with any of the files, here… I do have a question, are these files from the Glowforge catalog? there has been some discussion that people are having issues with them, as of late.


1 Like

thank you for your response.
I am working on a blank design at the moment. I am able to get it opened and started. I imported my design and then when placing and copy and pasting the program will crash and I will have to re render the page. it does keep my work but it is taking much longer to get anything accomplished. I did submit a ticket to support as well. I was just hoping someone else had an easy fix.

1 Like

I wish we could help, but Support will get to you - soon, I hope.

1 Like

The app has been glitchy for me too. All my saved files and importing files no longer worked on Safari. I’ve ran 100’s of repeat prints, so I know it’s not on my end. I chatted with support they suggested checking other browsers. I had success with firefox and now it’s acting up too. Font’s are missing, words missing. I was still able to print by importing new projects, going back to the original svg files. You might give that a try, if you haven’t already. Support acknowledged issues with Safari but the problem seems to have spread to other browsers. I imagine they are aware of it, but it would be nice to see an announcement if that’s the case. This image shows what it looked like in Firefox just now.

I’m sorry for the frustration while we look into this further, and I appreciate your patience while our team continues to work on this. We’ve made some changes on our end to improve performance when loading designs. Will you please let me know if you’re now able to open your designs from the dashboard? If you’re still having trouble, please let me know what the design or designs are named as they appear on your dashboard:

This information will help us as we continue to look into the issue.

we are still having heaps of problems getting designs to render. this is one that I need ASAP. this is causing a major problem with our business and it causing us to seriously reconsider our glowforge. there needs to be an offline mode that has a direct line to the computer that will just cut what we tell it to cut. this has been an ongoing issue for a week now!

1 Like

Hi @natemellen2004. Thank you for getting back to us, and I’m sorry to hear that the app is still giving you some trouble rendering designs for you. I saw that you had an opened chat and email thread for this as well, which we sent a response after this was posted in the Community. To avoid any potential confusion, or miscommunication, I am going to close this Community thread and we’ll look forward to your response in the email thread. Thank you!