First time trying pass through and it won’t work

Tried three times so far and it says it is processing my print but after an hour I gave up. Twice. Simply trying to engrave on draft board.

Not sure what to do and can’t find any information on why it can’t get past processing

I’m so sorry you’ve hit this snag!

When you noticed that the “Processing Print” step is taking too long, is it with every design you utilize, or one particular design?

If it is a single design, would it be possible to post a copy of the design for us to review?

I’d also like to review some information regarding your browser. When you have a moment, could you please do the following?

  1. Go to
  2. Look for the header that says “Your web browser’s unique URL”
  3. Click the button that says “Copy URL to Clipboard”
  4. Reply to this, and paste in the link provided

This will help us understand the circumstances around your error so we can work on it for you.

Once we can review these details, we’ll send over the next best steps.

Sorry it took so long to get back to you. I did what you said and went to that browser site and when I click on it all it said was, “your browser is out of date”. So I went to my settings and sure enough, I have been hitting the “remind me tomorrow” option every time it came up on my screen. So long story short, I updated my browser and tried again and it is currently working perfectly.

Thank you for getting back to me so quickly

1 Like

Thank you for letting us know. It’s great to hear that updating your browser got you back up and running! I’ll go ahead and close this topic. If you run into trouble again, or have any questions for us, please feel free to reach out again and we’ll be happy to help.