Focus Errors

hello - I am now getting the error “An error has occurred on your Glowforge…” every single time I try to focus. It doesn’t matter what material I am using. I have read a number of other posts about this issue and checked the clip and the metal bars are all straight - but not sure how to check the circuit board properly. Could someone please offer some help? Thanks!

I had a similar issue and GF sent out a new laser head. I didn’t have any issues with their support, they were very responsive… 5 stars.

That said, I wanted to give my 2 cents as this seems to be relatively frequent problem and may be it helps GF support resolve this.

So after the cut/engrave is done the laser head moves to the home position on the top left. The screen shows the cooling timer. AND the laser refocuses. This typically shows up on the screen top left as a tiny popup on a yellow banner, easy to miss. If you pay attention you can hear this happen but with the exhaust on it may be difficult.

If folks open the lid before the refocus process is completed, it might be kicking the refocus gears out of sync every time this happens. Then one day, boom, the gears are so off that the head can’t focus again.

This problem happens because the cool down timer shows cooling complete before the refocus is done. So obviously the user opens the lid (stopping the refocus procedure) thinking its ready.

Couple of solutions/software tweaks that could help:

  1. Make sure the cool down timer extends the time to include the time needed for refocusing to complete. However, this still doesn’t prevent the user from opening the lid (people in a hurry or excited to see the finished product).

  2. The better way would be to finish the refocusing procedure before homing the head. This way folks will be less inclined to open the lid if they see the head sitting in the middle.

All this is just from my observation. I may be completely wrong, it may not be relevant to this particular situation or at all and may not help GF support. :man_shrugging:

To be on the safe side I just give the machine a couple of additional minutes after the ready sign pops up and then open the lid.


If this is the focusing before you print, what does your material look like? Sometimes if there are lots of holes, or any sort of bright light the camera can get confused by the shadows. Do you have this issue when you have either nothing, or a full sheet of material on the bed? If there’s a window, try covering either it, or the :glowforge:

You can post photos of the circuit board/cable connections here and a staff member will review them.

As a test - attempt to run the Gift of Good Measure (in your dashboard) on a piece of PG material. Post the time of the attempt and a picture of your GFUI showing everything from the commands on left to the name of your machine on the right - this will allow a staff member to go to the logs for the correct time and figure out what’s confusing your machine.

For this, if you’re by your machine it does a specific set of clicks that ends with 4-5 in quick succession - if you have your skin against the lid you can actually feel them - when that last fast burst happens the refocusing is done :slight_smile:


That is a great point, I will be sure to remember to let the lens get back before opening the lid. I don’t think that is the issue here, but it’s definitely something to keep in mind moving forward. We lost power today so I haven’t been able to check anything out but am going to try tomorrow. THanks again for your response!

1 Like

Thank you for your response - this is happened to all materials, not matter what - but I will definitely give your suggestions a try. We have lost power today so I am hoping to be able to do this tomorrow. Thanks again for reading and responding!

1 Like

It may be too late for my suggestion to help you now, but I am hoping that GF support takes a serious look at it and for other users who may chance upon this thread before it is too late for them.

1 Like

Thank you - and same here. It sounds like they are pretty busy. I am going to try the suggestions you and deirdrebeth offered today. I have some cutting boards from IKEA that I want to engrave and I can’t seem to make any progress without being able to focus no matter what I do. (It’s my first time trying to print without the crumb tray!). Thanks again for checking in!

Are you having a material pre selected in your app or are you using and unknown material? No saying that is a factor/issue. Just curious

Hi @sibylsmith - sorry it’s taken us so long to get back to you!

I extracted some data from the recent focus attempts from your printer, and it looks like the printer is having a hard time spotting the red dot we use to measure material.

I’d like to start by cleaning off the bottom of the printer head? Specifically I want to check on these areas I’ve pointed out.

If you see any issues or want me to take a 2nd look at anything please share a photo like this one with me to review.

1 Like

Hi there - thank you for responding - I did try cleaning those areas and am still getting the same error.
Here is a pic of the areas you asked to see. Thanks!

@MyDogsThinkImCrazy - it’s happening with both options!

You need to clean off the cover on the right. I promise that black gunk will come off and you will get improved results.


OMG, I didn’t even realize that was gunk. I just thought it looked that way. I just cleaned it off and I am no longer getting the error!! Thank you SO MUCH - thankfully this was an easy fix. Now I am going to attempt my first cut without the crumb tray since I should be able to focus. Have a great weekend @dklgood !


@sibylsmith I’m glad you resolved it! Thank you @dklgood for your advice. I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!