Forging on!


#1

So guess what just showed up at my house!!

Okay, technically this came yesterday, but I was super busy and didn’t get a chance to post it. Had all 4 handles, which was nice and the box didn’t seem in too bad of shape. The forge made it just fine thankfully.

And here she is all set up!


Initial build impressions, the lid sits slightly high, it’s not a big deal, but it is annoying. Closing the front door panel feels far less quality than the rest of the machine and I’m not sure how I feel about that. Other than those issues, overall it seems well built.

On the software side, the only problem I am having, is that I wanted to print the awesome founders ruler, but I couldn’t find it on my dashboard… so there is that.
Anyone know if I missed something?

Also, for those keeping track:
I ordered the pro on 10/18/15
Got my golden letter on 10/26/17
Got my forge tracking number 11/17/17
And got the forge yesterday or 11/18/17

The filter is still a ways off, but I’m glad to have my glowforge. To those still waiting, keep your heads up, they are coming. It’s been a long wait, but it is most definitely worth it.


#2

Awesome! Congratulations! :grinning:
(There’s a “Show More” button at the bottom of the catalog page…did you try that?)


#3

Try leveling the glowforge itself or adding shim under it. I lifted on corner from underneath and the lid dropped into place.


#4

That’s a great idea, I’ll give that a shot. Thank you.

Yeah still cannot find my founder’s ruler, it’s not showing up anywhere. I’ll shoot an email to tech support and hopefully they can point me in the right direction.


#5

In app.glowforge.com click on ‘home’ and it should be listed as ‘Glowforge Founder’s Ruler’.


#6

Awesome news. Have fun with it!


#7

Yeah, that’s where I was looking, I also went to the catalog just in case, but nothing. This is what my home looks like as of right now just in case I’m blind:

(I can’t scroll down anymore, I tried that too and there is nothing more)


#8

Which browser and device (computer/tablet/?) and operating system?


#9

Odd. When I scroll down to the bottom of page 1, I see ‘SHOW MORE’. The scrolling is a little odd - I have to hover the mouse over the items (not, for example, the right margin) and use the scroll wheel or two fingers on the track pad to scroll the item listing down to the bottom, then I can click on ‘SHOW MORE’ to see page 2.


#10

There is a “show more” button at the bottom of your image. It looks greyed out perhaps it doesn’t do anything? I notice that your designs have prettier pictures than mine so I’m guessing that they snapshot them at the time you accept delivery.


#11

Chrome on a Laptop with Windows 10. Just to be thorough I clicked on the show more, but it didn’t do anything and I cannot scroll further down.

I even tried shrinking the window and scrolling that way, but nothing more showed up when I scrolled to the bottom. I emailed support though, so hopefully they can help me figure this out.

Despite the lack of founder’s ruler, I am really enjoying the forge so far and I’ll throw up some photos later when I get a chance.


#12

Do you have any extensions that are designed to lock down browser functions?
As @markwal notes, the show more button is visible and I am wondering if an extension is preventing selection.

Just as a reference, I am assuming that Chrome is up to date and not a beta version.


#13

If you haven’t already, please do contact support about the ruler image! Glad it’s working well otherwise!


#14

“Show more” is a PITA, surely the interface can continue to scroll our designs. After 20 years doing Web Design and leaving… I am continuously disappointed by interfaces. This is supposed to be fluid. I was sold that dream and designed for it. Now it seems that plus … is the option. Bored…and Disillusioned…